# CVE-2026-34606: Stored XSS in Frappe LMS

> Stored XSS in Frappe LMS allows attackers to inject malicious scripts, potentially leading to code execution or account takeover.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Apr 2026
- **Updated:** 3 Apr 2026
- **Also known as:** GHSA-qf5w-r34q-c7j2

## What is CVE-2026-34606?

CVE-2026-34606 is a medium-severity cross-site scripting vulnerability in frappe lms, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Frappe Learning Management System (LMS) is a learning system that helps users structure their content. From version 2.27.0 to before version 2.48.0, Frappe LMS was vulnerable to stored XSS. This issue has been patched in version 2.48.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-34606?

It affects 1 product.


Products: Frappe Learning.

## How do I fix CVE-2026-34606?

No fix has been published for CVE-2026-34606 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-34606 being exploited?

There is no known exploitation of CVE-2026-34606 in the wild and no public exploit code.

## Other vulnerabilities in frappe lms

- [CVE-2023-5555](https://insights.sbomify.com/CVE-2023-5555/): Cross-site Scripting (XSS) - Generic in frappe/lms (high 7.1)
- [CVE-2026-26977](https://insights.sbomify.com/CVE-2026-26977/): Frappe Learning Management System exposes details of unpublished courses to unauthorized users (medium 6.9)
- [CVE-2025-11280](https://insights.sbomify.com/CVE-2025-11280/): Frappe LMS Assignment Picture files direct request (medium 6.3)
- [CVE-2023-42807](https://insights.sbomify.com/CVE-2023-42807/): Frappe LMS SQL Injection Issue on People Page (medium 6.3)
- [CVE-2026-39415](https://insights.sbomify.com/CVE-2026-39415/): Frappe Learning Management System has Client-Side Manipulation of Quiz Scores (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34606 and fix it if it is affected.

What it is: CVE-2026-34606 is a medium-severity cross-site scripting vulnerability in frappe lms, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34606 in the wild and no public exploit code.

Affected product: frappe lms. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34606/ (Markdown: https://insights.sbomify.com/CVE-2026-34606/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34606
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34606
- OSV: https://osv.dev/vulnerability/CVE-2026-34606

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34606/
Summaries are generated and may contain mistakes; the official description above is the record.
