# CVE-2026-34610: leancrypto: Integer truncation in X.509 name parser enables certificate identity impersonation

> An integer truncation in the X.509 name parser allows attackers to craft certificates that impersonate victims, bypassing identity verification in PKCS#7 and code signing.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 3 Apr 2026
- **Also known as:** GHSA-636g-jxv4-v4gr, SUSE-SU-2026:21754-1, SUSE-SU-2026:21824-1, openSUSE-SU-2026:10563-1, openSUSE-SU-2026:20783-1

## What is CVE-2026-34610?

CVE-2026-34610 is a medium-severity vulnerability in smuellerDD leancrypto, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The leancrypto library is a cryptographic library that exclusively contains only PQC-resistant cryptographic algorithms. Prior to version 1.7.1, lc_x509_extract_name_segment() casts size_t vlen to uint8_t when storing the Common Name (CN) length. An attacker who crafts a certificate with CN = victim's CN + 256 bytes padding gets cn_size = (uint8_t)(256 + N) = N, where N is the victim's CN length. The first N bytes of the attacker's CN are the victim's identity. After parsing, the attacker's certificate has an identical CN to the victim's — enabling identity impersonation in PKCS#7 verification, certificate chain matching, and code signing. This issue has been patched in version 1.7.1.

Weakness: CWE-681 (Incorrect Conversion between Numeric Types)

## Which versions are affected by CVE-2026-34610?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `leancrypto` | openSUSE:Tumbleweed | All versions | 1.7.2-1.1 |

Products: Leancrypto Leancrypto.

## How do I fix CVE-2026-34610?

Upgrade to a fixed version.

## Is CVE-2026-34610 being exploited?

There is no known exploitation of CVE-2026-34610 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34610 and fix it if it is affected.

What it is: CVE-2026-34610 is a medium-severity vulnerability in smuellerDD leancrypto, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34610 in the wild and no public exploit code.

Affected product: smuellerDD leancrypto. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34610/ (Markdown: https://insights.sbomify.com/CVE-2026-34610/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34610
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34610
- OSV: https://osv.dev/vulnerability/CVE-2026-34610

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34610/
Summaries are generated and may contain mistakes; the official description above is the record.
