# CVE-2026-34725: dbgate-web: Stored XSS in applicationIcon leads to potential RCE in Electron due to unsafe renderer configuration

> Attackers can inject malicious scripts via SVG icons, leading to remote code execution in the Electron desktop app due to unsafe renderer configuration.

- **Severity:** High 8.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 3 Apr 2026
- **Also known as:** GHSA-35xm-qvjg-8m42

## What is CVE-2026-34725?

CVE-2026-34725 is a high-severity cross-site scripting vulnerability in dbgate, published on 2 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

DbGate is cross-platform database manager. From version 7.0.0 to before version 7.1.5, a stored XSS vulnerability exists in DbGate because attacker-controlled SVG icon strings are rendered as raw HTML without sanitization. In the web UI this allows script execution in another user's browser; in the Electron desktop app this can escalate to local code execution because Electron is configured with nodeIntegration: true and contextIsolation: false. This issue has been patched in version 7.1.5.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-34725?

2 open source packages ship an affected version, including dbgate-web.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dbgate-web` | npm | From 7.0.0 | 7.1.5 |
| `dbgate-web` | npm | From 7.0.0 | 7.1.5 |

## How do I fix CVE-2026-34725?

Upgrade dbgate-web to 7.1.5 or later.

## Is CVE-2026-34725 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34725 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34725 and fix it if it is affected.

What it is: CVE-2026-34725 is a high-severity cross-site scripting vulnerability in dbgate, published on 2 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34725 exists.

Affected packages and fixed versions:
- dbgate-web (npm): affected from 7.0.0; fixed in 7.1.5
- dbgate-web (npm): affected from 7.0.0; fixed in 7.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34725/ (Markdown: https://insights.sbomify.com/CVE-2026-34725/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34725
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34725
- OSV: https://osv.dev/vulnerability/CVE-2026-34725

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34725/
Summaries are generated and may contain mistakes; the official description above is the record.
