# CVE-2026-34729: phpMyFAQ: Stored XSS via Regex Bypass in Filter::removeAttributes()

> Stored XSS in phpMyFAQ allows attackers to inject malicious scripts via regex bypass, potentially leading to code execution.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 2 Apr 2026
- **Also known as:** GHSA-cv2g-8cj8-vgc7

## What is CVE-2026-34729?

CVE-2026-34729 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 2 Apr 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

phpMyFAQ is an open source FAQ web application. Prior to version 4.1.1, there is a stored XSS vulnerability via Regex Bypass in Filter::removeAttributes(). This issue has been patched in version 4.1.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-34729?

2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.1 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.1 |

Products: Phpmyfaq Phpmyfaq.

## How do I fix CVE-2026-34729?

Upgrade phpmyfaq/phpmyfaq to 4.1.1 or later.

## Is CVE-2026-34729 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34729 exists.

## Other vulnerabilities in Phpmyfaq Phpmyfaq

- [CVE-2023-0310](https://insights.sbomify.com/CVE-2023-0310/): Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq (critical 9.8)
- [CVE-2022-4407](https://insights.sbomify.com/CVE-2022-4407/): Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq (critical 9.8)
- [CVE-2017-11187](https://insights.sbomify.com/CVE-2017-11187/): Security feature bypass in n/a (critical 9.8)
- [CVE-2026-76213](https://insights.sbomify.com/CVE-2026-76213/): phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle (critical 9.1)
- [CVE-2026-76214](https://insights.sbomify.com/CVE-2026-76214/): phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34729 and fix it if it is affected.

What it is: CVE-2026-34729 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 2 Apr 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34729 exists.

Affected packages and fixed versions:
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.1
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34729/ (Markdown: https://insights.sbomify.com/CVE-2026-34729/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34729
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34729
- OSV: https://osv.dev/vulnerability/CVE-2026-34729

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34729/
Summaries are generated and may contain mistakes; the official description above is the record.
