# CVE-2026-3473: Improper file ownership validation in the Boards API allows unauthorised file access

> Authenticated users can access and download files belonging to other users or teams via crafted Boards API requests due to improper ownership validation.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 May 2026
- **Updated:** 22 May 2026
- **Also known as:** GHSA-7pf2-9c95-w332, GO-2026-5817

## What is CVE-2026-3473?

CVE-2026-3473 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 22 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to validate file ownership and access control, which allows an authenticated user to access and download files belonging to other users or teams via crafted Boards API requests using valid file IDs.. Mattermost Advisory ID: MMSA-2026-00620

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-3473?

9 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.15 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.15 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0+incompatible | 10.11.15+incompatible, 11.4.5+incompatible, 11.5.4+incompatible, 11.6.1+incompatible |
| `github.com/mattermost/mattermost-server` | Go | From 11.4.0 | 11.4.5 |
| `github.com/mattermost/mattermost-server` | Go | From 11.4.0 | 11.4.5 |
| `github.com/mattermost/mattermost-server` | Go | From 11.5.0 | 11.5.4 |
| `github.com/mattermost/mattermost-server` | Go | From 11.5.0 | 11.5.4 |
| `github.com/mattermost/mattermost-server` | Go | From 11.6.0 | 11.6.1 |
| `github.com/mattermost/mattermost-server` | Go | From 11.6.0 | 11.6.1 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2026-3473?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.15, 10.11.15+incompatible, 11.4.5+incompatible or 11.5.4+incompatible.

## Is CVE-2026-3473 being exploited?

There is no known exploitation of CVE-2026-3473 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-3473 and fix it if it is affected.

What it is: CVE-2026-3473 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 22 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-3473 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.15
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.15
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0+incompatible; fixed in 10.11.15+incompatible, 11.4.5+incompatible, 11.5.4+incompatible, 11.6.1+incompatible
- github.com/mattermost/mattermost-server (Go): affected from 11.4.0; fixed in 11.4.5
- github.com/mattermost/mattermost-server (Go): affected from 11.4.0; fixed in 11.4.5
- github.com/mattermost/mattermost-server (Go): affected from 11.5.0; fixed in 11.5.4
- github.com/mattermost/mattermost-server (Go): affected from 11.5.0; fixed in 11.5.4
- github.com/mattermost/mattermost-server (Go): affected from 11.6.0; fixed in 11.6.1
- github.com/mattermost/mattermost-server (Go): affected from 11.6.0; fixed in 11.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-3473/ (Markdown: https://insights.sbomify.com/CVE-2026-3473/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-3473
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-3473
- OSV: https://osv.dev/vulnerability/CVE-2026-3473

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-3473/
Summaries are generated and may contain mistakes; the official description above is the record.
