# CVE-2026-34743: XZ Utils: Buffer overflow in lzma_index_append()

> A buffer overflow in XZ Utils allows attackers to execute arbitrary code or cause denial of service via crafted compressed data.

- **Severity:** Low 1.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 21 Jul 2026
- **Also known as:** ALPINE-CVE-2026-34743, ALSA-2026:64787, ALSA-2026:89749, AZL-81800, AZL-81905, AZL-81908, BELL-CVE-2026-34743, CLEANSTART-2026-NK46628, CLSA-2026-1779894244, CLSA-2026-1780518704, DEBIAN-CVE-2026-34743, ECHO-54f0-42da-6974, GHSA-x872-m794-cxhv, JLSEC-2026-462, MGASA-2026-0084, OESA-2026-1853, RHSA-2026:64787, RHSA-2026:7647, RLSA-2026:64787, RLSA-2026:89749, SUSE-SU-2026:2051-1, SUSE-SU-2026:2052-1, SUSE-SU-2026:2118-1, SUSE-SU-2026:21729-1, SUSE-SU-2026:21740-1, SUSE-SU-2026:21835-1, SUSE-SU-2026:21848-1, UBUNTU-CVE-2026-34743, USN-8362-1, openSUSE-SU-2026:10492-1, openSUSE-SU-2026:20813-1

## What is CVE-2026-34743?

CVE-2026-34743 is a low-severity memory corruption vulnerability in tukaani-project xz, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XZ Utils provide a general-purpose data-compression library plus command-line tools. Prior to version 5.8.3, if lzma_index_decoder() was used to decode an Index that contained no Records, the resulting lzma_index was left in a state where where a subsequent lzma_index_append() would allocate too little memory, and a buffer overflow would occur. This issue has been patched in version 5.8.3.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-34743?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xz` | AlmaLinux:10 | All versions | 1:5.6.2-4.el10_2.1 |
| `xz-devel` | AlmaLinux:10 | All versions | 1:5.6.2-4.el10_2.1 |
| `xz-libs` | AlmaLinux:10 | All versions | 1:5.6.2-4.el10_2.1 |
| `xz-lzma-compat` | AlmaLinux:10 | All versions | 1:5.6.2-4.el10_2.1 |
| `xz` | AlmaLinux:9 | All versions | 5.2.5-8.el9_8.1 |
| `xz-devel` | AlmaLinux:9 | All versions | 5.2.5-8.el9_8.1 |
| `xz-libs` | AlmaLinux:9 | All versions | 5.2.5-8.el9_8.1 |
| `xz-lzma-compat` | AlmaLinux:9 | All versions | 5.2.5-8.el9_8.1 |
| `xz` | Red Hat:enterprise_linux:10.2 | All versions | 1:5.6.2-4.el10_2.1 |
| `xz-debuginfo` | Red Hat:enterprise_linux:10.2 | All versions | 1:5.6.2-4.el10_2.1 |
| `xz-debugsource` | Red Hat:enterprise_linux:10.2 | All versions | 1:5.6.2-4.el10_2.1 |
| `xz-devel` | Red Hat:enterprise_linux:10.2 | All versions | 1:5.6.2-4.el10_2.1 |
| `xz-libs` | Red Hat:enterprise_linux:10.2 | All versions | 1:5.6.2-4.el10_2.1 |
| `xz-libs-debuginfo` | Red Hat:enterprise_linux:10.2 | All versions | 1:5.6.2-4.el10_2.1 |
| `xz-lzma-compat` | Red Hat:enterprise_linux:10.2 | All versions | 1:5.6.2-4.el10_2.1 |
| `xz-lzma-compat-debuginfo` | Red Hat:enterprise_linux:10.2 | All versions | 1:5.6.2-4.el10_2.1 |
| `xz` | Red Hat:hummingbird:1 | All versions | 0:5.8.3-1.1.hum1 |
| `xz-devel` | Red Hat:hummingbird:1 | All versions | 0:5.8.3-1.1.hum1 |
| `xz-libs` | Red Hat:hummingbird:1 | All versions | 0:5.8.3-1.1.hum1 |
| `xz-lzma-compat` | Red Hat:hummingbird:1 | All versions | 0:5.8.3-1.1.hum1 |
| `xz-static` | Red Hat:hummingbird:1 | All versions | 0:5.8.3-1.1.hum1 |
| `xz` | Rocky Linux:10 | All versions | 1:5.6.2-4.el10_2.1 |
| `xz` | Rocky Linux:9 | All versions | 0:5.2.5-8.el9_8.1 |
| `xz` | openSUSE:Tumbleweed | All versions | 5.8.3-1.1 |

Products: Tukaani Xz.

## How do I fix CVE-2026-34743?

Upgrade to a fixed version.

## Is CVE-2026-34743 being exploited?

There is no known exploitation of CVE-2026-34743 in the wild and no public exploit code.

## Other vulnerabilities in tukaani-project xz

- [CVE-2024-3094](https://insights.sbomify.com/CVE-2024-3094/): Xz: malicious code in distributed source (critical 10.0)
- [CVE-2015-4035](https://insights.sbomify.com/CVE-2015-4035/): Command injection in n/a (high 7.8)
- [CVE-2020-22916](https://insights.sbomify.com/CVE-2020-22916/): Denial of service in n/a (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34743 and fix it if it is affected.

What it is: CVE-2026-34743 is a low-severity memory corruption vulnerability in tukaani-project xz, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34743 in the wild and no public exploit code.

Affected product: tukaani-project xz. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34743/ (Markdown: https://insights.sbomify.com/CVE-2026-34743/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34743
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34743
- OSV: https://osv.dev/vulnerability/CVE-2026-34743

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34743/
Summaries are generated and may contain mistakes; the official description above is the record.
