{"answers":{"affected":"3 open source packages ship an affected version, including vllm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-34753 in the wild and no public exploit code.","fix":"Upgrade vllm to 0.19.0 or later.","what":"CVE-2026-34753 is a medium-severity server-side request forgery vulnerability in Vllm Vllm, published on 6 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-34753 and fix it if it is affected.\n\nWhat it is: CVE-2026-34753 is a medium-severity server-side request forgery vulnerability in Vllm Vllm, published on 6 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-34753 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.16.0; fixed in 0.19.0\n- vllm (PyPI): affected from 0.16.0; fixed in 0.19.0\n- vllm (PyPI): affected from 0.16.0; fixed in 0.19.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-34753/ (Markdown: https://insights.sbomify.com/CVE-2026-34753/index.md)","id":"CVE-2026-34753","markdown":"https://insights.sbomify.com/CVE-2026-34753/index.md","name":"CVE-2026-34753","record":{"aliases":["GHSA-pf3h-qjgv-vcpr","PYSEC-2026-3410"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM inference engine","requires_auth":"low_privilege","summary":"Attackers can force the vLLM server to make arbitrary HTTP requests, potentially accessing internal services or cloud metadata endpoints.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"vLLM is an inference and serving engine for large language models (LLMs). From 0.16.0 to before 0.19.0, a server-side request forgery (SSRF) vulnerability in download_bytes_from_url allows any actor who can control batch input JSON to make the vLLM batch runner issue arbitrary HTTP/HTTPS requests from the server, without any URL validation or domain restrictions.\nThis can be used to target internal services (e.g. cloud metadata endpoints or internal HTTP APIs) reachable from the vLLM host. This vulnerability is fixed in 0.19.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2026-05-03","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-05-03T19:05:44Z","kind":"github_poc","ref":"https://github.com/Dhiaelhak-Rached/CVE-2026-34753","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"vLLM affected by Server-Side Request Forgery (SSRF) in `download_bytes_from_url `","id":"CVE-2026-34753","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":"ssrf","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"MantisBT allows unauthorized users to upload attachments to restricted issues via REST API","id":"CVE-2026-34754"},"packages":[{"ecosystem":"PyPI","fixed":["0.19.0"],"introduced":["0.16.0"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-pf3h-qjgv-vcpr"},{"ecosystem":"PyPI","fixed":["0.19.0"],"introduced":["0.16.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-pf3h-qjgv-vcpr"},{"ecosystem":"PyPI","fixed":["0.19.0"],"introduced":["0.16.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2026-3410"}],"prev":{"headline":"Haraka affected by DoS via `__proto__` email header","id":"CVE-2026-34752"},"products":["vllm"],"published":"2026-04-06","related":[{"cvss_score":10,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":9.8,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.1,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","kev_date_added":null,"published":"2025-03-19"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-07","vendors":["vllm-project"]},"summary":"Attackers can force the vLLM server to make arbitrary HTTP requests, potentially accessing internal services or cloud metadata endpoints.","url":"https://insights.sbomify.com/CVE-2026-34753/"}