# CVE-2026-34756: vLLM Affected by Unauthenticated OOM Denial of Service via Unbounded `n` Parameter in OpenAI API Server

> Unauthenticated attackers can crash vLLM servers by sending requests with excessively large 'n' parameters, causing out-of-memory errors.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-3mwp-wvh9-7528, PYSEC-2026-2298

## What is CVE-2026-34756?

CVE-2026-34756 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 6 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.19.0, a Denial of Service vulnerability exists in the vLLM OpenAI-compatible API server. Due to the lack of an upper bound validation on the n parameter in the ChatCompletionRequest and CompletionRequest Pydantic models, an unauthenticated attacker can send a single HTTP request with an astronomically large n value. This completely blocks the Python asyncio event loop and causes immediate Out-Of-Memory crashes by allocating millions of request object copies in the heap before the request even reaches the scheduling queue. This vulnerability is fixed in 0.19.0.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input), CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-34756?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.1.0 | 0.19.0 |
| `vllm` | PyPI | From 0.1.0 | 0.19.0 |
| `vllm` | PyPI | From 0.1.0 | 0.19.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-34756?

Upgrade vllm to 0.19.0 or later.

## Is CVE-2026-34756 being exploited?

There is no known exploitation of CVE-2026-34756 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34756 and fix it if it is affected.

What it is: CVE-2026-34756 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 6 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34756 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.1.0; fixed in 0.19.0
- vllm (PyPI): affected from 0.1.0; fixed in 0.19.0
- vllm (PyPI): affected from 0.1.0; fixed in 0.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34756/ (Markdown: https://insights.sbomify.com/CVE-2026-34756/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34756
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34756
- OSV: https://osv.dev/vulnerability/CVE-2026-34756

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34756/
Summaries are generated and may contain mistakes; the official description above is the record.
