# CVE-2026-34757: Use after free in libpng

> Attackers can trigger a use-after-free in libpng setters to leak heap data or corrupt chunk metadata by passing freed pointers back to the library.

- **Severity:** Medium 5.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 9 May 2026
- **Also known as:** ALPINE-CVE-2026-34757, AZL-82643, AZL-85478, AZL-85481, AZL-85484, AZL-85487, AZL-85490, AZL-85493, BELL-CVE-2026-34757, CLEANSTART-2026-OQ43159, CLSA-2026-1778891359, CLSA-2026-1778928586, CLSA-2026-1779127797, CLSA-2026-1779129500, DEBIAN-CVE-2026-34757, ECHO-7edb-b098-20d5, GHSA-6fr7-g8h7-v645, JLSEC-2026-498, MINI-5xjv-chvq-q5f9, OESA-2026-2149, RHSA-2026:13719, SUSE-SU-2026:1601-1, SUSE-SU-2026:1602-1, SUSE-SU-2026:2057-1, SUSE-SU-2026:21239-1, SUSE-SU-2026:21251-1, SUSE-SU-2026:21262-1, SUSE-SU-2026:21364-1, UBUNTU-CVE-2026-34757, openSUSE-SU-2026:10564-1, openSUSE-SU-2026:20593-1

## What is CVE-2026-34757?

CVE-2026-34757 is a medium-severity use after free vulnerability in Debian Debian Linux, published on 9 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. From 1.0.9 to before 1.6.57, passing a pointer obtained from png_get_PLTE, png_get_tRNS, or png_get_hIST back into the corresponding setter on the same png_struct/png_info pair causes the setter to read from freed memory and copy its contents into the replacement buffer. The setter frees the internal buffer before copying from the caller-supplied pointer, which now dangles. The freed region may contain stale data (producing silently corrupted chunk metadata) or data from subsequent heap allocations (leaking unrelated heap contents into the chunk struct). This vulnerability is fixed in 1.6.57.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-34757?

It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libpng` | Red Hat:hummingbird:1 | All versions | 0:1.6.57-0.1.hum1 |
| `libpng-devel` | Red Hat:hummingbird:1 | All versions | 0:1.6.57-0.1.hum1 |
| `libpng-static` | Red Hat:hummingbird:1 | All versions | 0:1.6.57-0.1.hum1 |
| `libpng-tools` | Red Hat:hummingbird:1 | All versions | 0:1.6.57-0.1.hum1 |
| `libpng16` | SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 1.6.40-150600.3.20.1 |
| `libpng16` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 1.6.8-15.24.1 |
| `libpng16` | SUSE:Linux Micro 6.0 | All versions | 1.6.43-5.1 |
| `libpng16` | SUSE:Linux Micro 6.1 | All versions | 1.6.43-slfo.1.1_5.1 |
| `libpng16` | SUSE:Linux Micro 6.2 | All versions | 1.6.44-160000.7.1 |
| `libpng16` | openSUSE:Leap 16.0 | All versions | 1.6.44-160000.7.1 |
| `libpng16` | openSUSE:Tumbleweed | All versions | 1.6.57-1.1 |

Products: Debian Debian Linux, Libpng Libpng.

## How do I fix CVE-2026-34757?

Upgrade to a fixed version.

## Is CVE-2026-34757 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34757 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34757 and fix it if it is affected.

What it is: CVE-2026-34757 is a medium-severity use after free vulnerability in Debian Debian Linux, published on 9 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34757 exists.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34757/ (Markdown: https://insights.sbomify.com/CVE-2026-34757/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34757
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34757
- OSV: https://osv.dev/vulnerability/CVE-2026-34757

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34757/
Summaries are generated and may contain mistakes; the official description above is the record.
