CVE-2026-34760 vLLM: Downmix Implementation Differences as Attack Vectors Against Audio AI Models

Medium 5.9 Published Updated

Attackers can exploit audio downmixing discrepancies to manipulate AI model inputs, affecting audio processing integrity in vLLM.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-34760?

CVE-2026-34760 is a medium-severity vulnerability in Vllm Vllm, published on 2 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before version 0.18.0, Librosa defaults to using numpy.mean for mono downmixing (to_mono), while the international standard ITU-R BS.775-4 specifies a weighted downmixing algorithm. This discrepancy results in inconsistency between audio heard by humans (e.g., through headphones/regular speakers) and audio processed by AI models (Which infra via Librosa, such as vllm, transformer). This issue has been patched in version 0.18.0.

Weakness: CWE-20

Which versions are affected by CVE-2026-34760?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIFrom 0.5.50.18.0
vllm PyPIFrom 0.5.50.18.0
vllm PyPIFrom 0.5.50.18.0

Products include Vllm Vllm.

How do I fix CVE-2026-34760?

Upgrade vllm to 0.18.0 or later.

Is CVE-2026-34760 being exploited?

There is no known exploitation of CVE-2026-34760 in the wild and no public exploit code.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-6c4r-fmh3-7rh8, PYSEC-2026-2299.

Is CVE-2026-34760 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free