# CVE-2026-34763: Rack: Rack::Directory info disclosure and DoS via unescaped regex interpolation

> Attackers can expose full filesystem paths and cause denial of service in Rack::Directory due to unescaped regex interpolation of the root path.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 2 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-34763, GHSA-7mqq-6cf9-v2qp, MINI-5jv8-pc96-jvx6, MINI-6w4q-43j9-pg95, MINI-78j4-q88f-gj4p, MINI-7w4m-296h-gppm, MINI-8wv9-3j5v-w99c, MINI-9hv7-27fg-rcx3, MINI-9jpr-hrwq-mj7g, MINI-c5p6-gj6x-v6j7, MINI-f375-cccf-3796, MINI-j5vh-hfw2-pr25, MINI-j723-864v-cffp, MINI-jmff-p8v7-6r26, MINI-jv5j-pxmc-cp5x, MINI-m7cg-p949-j3m9, MINI-mgv6-748f-vvr5, MINI-pg6j-4gr5-hvm2, MINI-qxwf-mprp-433m, MINI-rc2g-4879-gfch, MINI-rch2-3hg7-rxrw, MINI-rj5x-38jh-5m8j, MINI-rwwr-pp5j-mjh2, MINI-w96r-p47h-5c6f, MINI-wfp9-q4m4-7922, MINI-x889-4pwm-c23m, UBUNTU-CVE-2026-34763

## What is CVE-2026-34763?

CVE-2026-34763 is a medium-severity vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Directory interpolates the configured root path directly into a regular expression when deriving the displayed directory path. If root contains regex metacharacters such as +, *, or ., the prefix stripping can fail and the generated directory listing may expose the full filesystem path in the HTML output. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.

Weakness: CWE-625 (Permissive Regular Expression)

## Which versions are affected by CVE-2026-34763?

6 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.2.23 |
| `rack` | RubyGems | All versions | 2.2.23 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |

Products: Rack Rack.

## How do I fix CVE-2026-34763?

Upgrade rack to a fixed version for your release line: 2.2.23, 3.1.21 or 3.2.6.

## Is CVE-2026-34763 being exploited?

There is no known exploitation of CVE-2026-34763 in the wild and no public exploit code.

## Other vulnerabilities in rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34763 and fix it if it is affected.

What it is: CVE-2026-34763 is a medium-severity vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34763 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.2.23
- rack (RubyGems): affected all versions; fixed in 2.2.23
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34763/ (Markdown: https://insights.sbomify.com/CVE-2026-34763/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34763
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34763
- OSV: https://osv.dev/vulnerability/CVE-2026-34763

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34763/
Summaries are generated and may contain mistakes; the official description above is the record.
