CVE-2026-34766 Electron: USB device selection not validated against filtered device list
Electron apps may grant USB device access outside intended filters due to missing validation, bypassing security restrictions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-34766?
CVE-2026-34766 is a low-severity missing authorization vulnerability in Electronjs Electron, published on 3 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. Prior to versions 38.8.6, 39.8.0, 40.7.0, and 41.0.0-beta.8, the select-usb-device event callback did not validate the chosen device ID against the filtered list that was presented to the handler. An app whose handler could be influenced to select a device ID outside the filtered set would grant access to a device that did not match the renderer's requested filters or was listed in exclusionFilters. The WebUSB security blocklist remained enforced regardless, so security-sensitive devices on the blocklist were not affected. The practical impact is limited to apps with unusual device-selection logic. This issue has been patched in versions 38.8.6, 39.8.0, 40.7.0, and 41.0.0-beta.8.
Weakness: CWE-862
Which versions are affected by CVE-2026-34766?
8 open source packages ship an affected version, including electron. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
electron npm | All versions | 38.8.6 |
electron npm | All versions | 38.8.6 |
electron npm | From 39.0.0-alpha.1 | 39.8.0 |
electron npm | From 39.0.0-alpha.1 | 39.8.0 |
electron npm | From 40.0.0-alpha.1 | 40.7.0 |
electron npm | From 40.0.0-alpha.1 | 40.7.0 |
2 more packages
electron npm | From 41.0.0-alpha.1 | 41.0.0-beta.8 |
electron npm | From 41.0.0-alpha.1 | 41.0.0-beta.8 |
Products include Electronjs Electron.
How do I fix CVE-2026-34766?
Upgrade electron to a fixed version for your release line: 38.8.6, 39.8.0, 40.7.0 or 41.0.0-beta.8.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-34766 being exploited?
There is no known exploitation of CVE-2026-34766 in the wild and no public exploit code.
Other vulnerabilities in Electronjs Electron
- CVE-2017-16151 Chromium Remote Code Execution in electron
- CVE-2018-1000118 Electron protocol handler browser vulnerable to Command Injection
- CVE-2026-34780 Electron: Context Isolation bypass via contextBridge VideoFrame transfer
- CVE-2026-102676 Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions
- CVE-2026-102673 Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab
Sources
Also known as GHSA-9899-m83m-qhpj.