# CVE-2026-34770: Electron: Use-after-free in PowerMonitor on Windows and macOS

> Attackers can trigger a use-after-free in Electron's PowerMonitor module, potentially causing application crashes or arbitrary code execution.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Apr 2026
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-jjp3-mq3x-295m

## What is CVE-2026-34770?

CVE-2026-34770 is a high-severity use after free vulnerability in Electronjs Electron, published on 3 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. Prior to versions 38.8.6, 39.8.1, 40.8.0, and 41.0.0-beta.8, apps that use the powerMonitor module may be vulnerable to a use-after-free. After the native PowerMonitor object is garbage-collected, the associated OS-level resources (a message window on Windows, a shutdown handler on macOS) retain dangling references. A subsequent session-change event (Windows) or system shutdown (macOS) dereferences freed memory, which may lead to a crash or memory corruption. All apps that access powerMonitor events (suspend, resume, lock-screen, etc.) are potentially affected. The issue is not directly renderer-controllable. This issue has been patched in versions 38.8.6, 39.8.1, 40.8.0, and 41.0.0-beta.8.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-34770?

8 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | All versions | 38.8.6 |
| `electron` | npm | All versions | 38.8.6 |
| `electron` | npm | From 39.0.0-alpha.1 | 39.8.1 |
| `electron` | npm | From 39.0.0-alpha.1 | 39.8.1 |
| `electron` | npm | From 40.0.0-alpha.1 | 40.8.0 |
| `electron` | npm | From 40.0.0-alpha.1 | 40.8.0 |
| `electron` | npm | From 41.0.0-alpha.1 | 41.0.0-beta.8 |
| `electron` | npm | From 41.0.0-alpha.1 | 41.0.0-beta.8 |

Products: Electronjs Electron.

## How do I fix CVE-2026-34770?

Upgrade electron to a fixed version for your release line: 38.8.6, 39.8.1, 40.8.0 or 41.0.0-beta.8.

## Is CVE-2026-34770 being exploited?

There is no known exploitation of CVE-2026-34770 in the wild and no public exploit code.

## Other vulnerabilities in Electronjs Electron

- [CVE-2017-16151](https://insights.sbomify.com/CVE-2017-16151/): Chromium Remote Code Execution in electron (critical 9.8)
- [CVE-2018-1000118](https://insights.sbomify.com/CVE-2018-1000118/): Electron protocol handler browser vulnerable to Command Injection (high 8.8)
- [CVE-2026-34780](https://insights.sbomify.com/CVE-2026-34780/): Electron: Context Isolation bypass via contextBridge VideoFrame transfer (high 8.4)
- [CVE-2026-102676](https://insights.sbomify.com/CVE-2026-102676/): Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions (high 8.3)
- [CVE-2026-102673](https://insights.sbomify.com/CVE-2026-102673/): Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34770 and fix it if it is affected.

What it is: CVE-2026-34770 is a high-severity use after free vulnerability in Electronjs Electron, published on 3 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-34770 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected all versions; fixed in 38.8.6
- electron (npm): affected all versions; fixed in 38.8.6
- electron (npm): affected from 39.0.0-alpha.1; fixed in 39.8.1
- electron (npm): affected from 39.0.0-alpha.1; fixed in 39.8.1
- electron (npm): affected from 40.0.0-alpha.1; fixed in 40.8.0
- electron (npm): affected from 40.0.0-alpha.1; fixed in 40.8.0
- electron (npm): affected from 41.0.0-alpha.1; fixed in 41.0.0-beta.8
- electron (npm): affected from 41.0.0-alpha.1; fixed in 41.0.0-beta.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34770/ (Markdown: https://insights.sbomify.com/CVE-2026-34770/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34770
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34770
- OSV: https://osv.dev/vulnerability/CVE-2026-34770

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34770/
Summaries are generated and may contain mistakes; the official description above is the record.
