# CVE-2026-34776: Electron: Out-of-bounds read in second-instance IPC on macOS and Linux

> An out-of-bounds read in Electron's second-instance IPC allows local attackers to leak memory to the application's event handler.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2026
- **Updated:** 6 Apr 2026
- **Also known as:** GHSA-3c8v-cfp5-9885

## What is CVE-2026-34776?

CVE-2026-34776 is a medium-severity vulnerability in Electronjs Electron, published on 3 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. Prior to versions 38.8.6, 39.8.1, 40.8.1, and 41.0.0, on macOS and Linux, apps that call app.requestSingleInstanceLock() were vulnerable to an out-of-bounds heap read when parsing a crafted second-instance message. Leaked memory could be delivered to the app's second-instance event handler. This issue is limited to processes running as the same user as the Electron app. Apps that do not call app.requestSingleInstanceLock() are not affected. Windows is not affected by this issue. This issue has been patched in versions 38.8.6, 39.8.1, 40.8.1, and 41.0.0.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-34776?

8 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | All versions | 38.8.6 |
| `electron` | npm | All versions | 38.8.6 |
| `electron` | npm | From 39.0.0-alpha.1 | 39.8.1 |
| `electron` | npm | From 39.0.0-alpha.1 | 39.8.1 |
| `electron` | npm | From 40.0.0-alpha.1 | 40.8.1 |
| `electron` | npm | From 40.0.0-alpha.1 | 40.8.1 |
| `electron` | npm | From 41.0.0-alpha.1 | 41.0.0 |
| `electron` | npm | From 41.0.0-alpha.1 | 41.0.0 |

Products: Electronjs Electron.

## How do I fix CVE-2026-34776?

Upgrade electron to a fixed version for your release line: 38.8.6, 39.8.1, 40.8.1 or 41.0.0.

## Is CVE-2026-34776 being exploited?

There is no known exploitation of CVE-2026-34776 in the wild and no public exploit code.

## Other vulnerabilities in Electronjs Electron

- [CVE-2017-16151](https://insights.sbomify.com/CVE-2017-16151/): Chromium Remote Code Execution in electron (critical 9.8)
- [CVE-2018-1000118](https://insights.sbomify.com/CVE-2018-1000118/): Electron protocol handler browser vulnerable to Command Injection (high 8.8)
- [CVE-2026-34780](https://insights.sbomify.com/CVE-2026-34780/): Electron: Context Isolation bypass via contextBridge VideoFrame transfer (high 8.4)
- [CVE-2026-102676](https://insights.sbomify.com/CVE-2026-102676/): Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions (high 8.3)
- [CVE-2026-102673](https://insights.sbomify.com/CVE-2026-102673/): Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34776 and fix it if it is affected.

What it is: CVE-2026-34776 is a medium-severity vulnerability in Electronjs Electron, published on 3 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34776 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected all versions; fixed in 38.8.6
- electron (npm): affected all versions; fixed in 38.8.6
- electron (npm): affected from 39.0.0-alpha.1; fixed in 39.8.1
- electron (npm): affected from 39.0.0-alpha.1; fixed in 39.8.1
- electron (npm): affected from 40.0.0-alpha.1; fixed in 40.8.1
- electron (npm): affected from 40.0.0-alpha.1; fixed in 40.8.1
- electron (npm): affected from 41.0.0-alpha.1; fixed in 41.0.0
- electron (npm): affected from 41.0.0-alpha.1; fixed in 41.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34776/ (Markdown: https://insights.sbomify.com/CVE-2026-34776/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34776
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34776
- OSV: https://osv.dev/vulnerability/CVE-2026-34776

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34776/
Summaries are generated and may contain mistakes; the official description above is the record.
