# CVE-2026-34780: Electron: Context Isolation bypass via contextBridge VideoFrame transfer

> Attackers can bypass context isolation in Electron apps using bridged VideoFrame objects to access Node.js APIs, requiring an upgrade to patched versions.

- **Severity:** High 8.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-jfqg-hf23-qpw2

## What is CVE-2026-34780?

CVE-2026-34780 is a high-severity vulnerability in Electronjs Electron, published on 4 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. From versions 39.0.0-alpha.1 to before 39.8.0, 40.0.0-alpha.1 to before 40.7.0, and 41.0.0-alpha.1 to before 41.0.0-beta.8, apps that pass VideoFrame objects (from the WebCodecs API) across the contextBridge are vulnerable to a context isolation bypass. An attacker who can execute JavaScript in the main world (for example, via XSS) can use a bridged VideoFrame to gain access to the isolated world, including any Node.js APIs exposed to the preload script. Apps are only affected if a preload script returns, resolves, or passes a VideoFrame object to the main world via contextBridge.exposeInMainWorld(). Apps that do not bridge VideoFrame objects are not affected. This issue has been patched in versions 39.8.0, 40.7.0, and 41.0.0-beta.8.

Weakness: CWE-501 (Trust Boundary Violation), CWE-668 (Exposure of Resource to Wrong Sphere), CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2026-34780?

6 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | From 39.0.0-alpha.1 | 39.8.0 |
| `electron` | npm | From 39.0.0-alpha.1 | 39.8.0 |
| `electron` | npm | From 40.0.0-alpha.1 | 40.7.0 |
| `electron` | npm | From 40.0.0-alpha.1 | 40.7.0 |
| `electron` | npm | From 41.0.0-alpha.1 | 41.0.0-beta.8 |
| `electron` | npm | From 41.0.0-alpha.1 | 41.0.0-beta.8 |

Products: Electronjs Electron.

## How do I fix CVE-2026-34780?

Upgrade electron to a fixed version for your release line: 39.8.0, 40.7.0 or 41.0.0-beta.8.

## Is CVE-2026-34780 being exploited?

There is no known exploitation of CVE-2026-34780 in the wild and no public exploit code.

## Other vulnerabilities in Electronjs Electron

- [CVE-2017-16151](https://insights.sbomify.com/CVE-2017-16151/): Chromium Remote Code Execution in electron (critical 9.8)
- [CVE-2018-1000118](https://insights.sbomify.com/CVE-2018-1000118/): Electron protocol handler browser vulnerable to Command Injection (high 8.8)
- [CVE-2026-102676](https://insights.sbomify.com/CVE-2026-102676/): Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions (high 8.3)
- [CVE-2026-102673](https://insights.sbomify.com/CVE-2026-102673/): Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab (high 8.2)
- [CVE-2026-102674](https://insights.sbomify.com/CVE-2026-102674/): Electron: Windows opened from a sandboxed top-level document do not inherit its sandbox restrictions (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34780 and fix it if it is affected.

What it is: CVE-2026-34780 is a high-severity vulnerability in Electronjs Electron, published on 4 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-34780 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected from 39.0.0-alpha.1; fixed in 39.8.0
- electron (npm): affected from 39.0.0-alpha.1; fixed in 39.8.0
- electron (npm): affected from 40.0.0-alpha.1; fixed in 40.7.0
- electron (npm): affected from 40.0.0-alpha.1; fixed in 40.7.0
- electron (npm): affected from 41.0.0-alpha.1; fixed in 41.0.0-beta.8
- electron (npm): affected from 41.0.0-alpha.1; fixed in 41.0.0-beta.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34780/ (Markdown: https://insights.sbomify.com/CVE-2026-34780/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34780
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34780
- OSV: https://osv.dev/vulnerability/CVE-2026-34780

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34780/
Summaries are generated and may contain mistakes; the official description above is the record.
