# CVE-2026-34785: Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching

> Attackers can read sensitive files by exploiting prefix matching in Rack::Static, requiring specific configuration to expose unintended files.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-34785, GHSA-h2jq-g4cq-5ppq, MINI-2rjv-48v3-hp9w, MINI-2vpc-fx7j-9jqx, MINI-3r9g-3cm3-m7hr, MINI-3vmh-r8r5-pgpr, MINI-6c3c-rmmm-wpqh, MINI-7c94-3jcm-mqvg, MINI-7xxh-v6hh-4chf, MINI-f8mp-wjfc-756j, MINI-fr86-m9jg-jjvp, MINI-hj73-v9fq-73g7, MINI-j9cm-q584-74qq, MINI-m2wc-jj53-w9r6, MINI-mh4f-8cq4-pcpq, MINI-mjj7-rp7c-w4x3, MINI-mr7p-6c95-vgc7, MINI-p748-mmxh-732p, MINI-r7wv-frgv-5gff, MINI-rh8f-g7cq-5p7v, MINI-rxcv-rghv-6wr2, MINI-vcr2-h3v6-c7fj, MINI-vrff-2795-fmwq, MINI-wq6p-5vv9-99ww, MINI-xm5q-8273-g3xw, MINI-xmvc-g9rg-rr77, UBUNTU-CVE-2026-34785

## What is CVE-2026-34785?

CVE-2026-34785 is a high-severity path traversal vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Static determines whether a request should be served as a static file using a simple string prefix check. When configured with URL prefixes such as "/css", it matches any request path that begins with that string, including unrelated paths such as "/css-config.env" or "/css-backup.sql". As a result, files under the static root whose names merely share the configured prefix may be served unintentionally, leading to information disclosure. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.

Weakness: CWE-552 (Files or Directories Accessible to External Parties), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), CWE-187 (Partial String Comparison)

## Which versions are affected by CVE-2026-34785?

6 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.2.23 |
| `rack` | RubyGems | All versions | 2.2.23 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |

Products: Rack Rack.

## How do I fix CVE-2026-34785?

Upgrade rack to a fixed version for your release line: 2.2.23, 3.1.21 or 3.2.6.

## Is CVE-2026-34785 being exploited?

There is no known exploitation of CVE-2026-34785 in the wild and no public exploit code.

## Other vulnerabilities in rack

- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)
- [CVE-2025-61770](https://insights.sbomify.com/CVE-2025-61770/): Rack's unbounded multipart preamble buffering enables DoS (memory exhaustion) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34785 and fix it if it is affected.

What it is: CVE-2026-34785 is a high-severity path traversal vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34785 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.2.23
- rack (RubyGems): affected all versions; fixed in 2.2.23
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34785/ (Markdown: https://insights.sbomify.com/CVE-2026-34785/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34785
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34785
- OSV: https://osv.dev/vulnerability/CVE-2026-34785

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34785/
Summaries are generated and may contain mistakes; the official description above is the record.
