# CVE-2026-34826: Rack: Unbounded Range Count in get_byte_ranges Enables DoS

> Attackers can cause denial of service in Rack by sending HTTP Range headers with excessive byte ranges, consuming disproportionate resources.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 3 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-34826, GHSA-x8cg-fq8g-mxfx, MINI-2jcq-p6qw-pcpv, MINI-2rxg-xqj7-h547, MINI-623g-wg9g-j44x, MINI-632x-3f96-93wc, MINI-6rg3-7x3v-p87x, MINI-7qq4-xcjf-74qf, MINI-85q6-v78p-7hcg, MINI-8rxh-pc47-824h, MINI-8v5p-j7x6-mxph, MINI-98hx-fc58-q9wm, MINI-c59p-5w7f-gqhm, MINI-f4h9-m8qg-p9rx, MINI-f7g6-26r2-v39h, MINI-g3c5-cmqm-87w4, MINI-gv7m-6473-g9rv, MINI-h86m-6mph-9983, MINI-jcx6-7v53-jpx6, MINI-jmhh-qrpm-fw48, MINI-q6rg-522w-wr8f, MINI-qxh9-5mp4-gp2h, MINI-r4v9-m6p6-m6qj, MINI-v7vj-76r9-cx3q, MINI-vfxc-rx29-rmcf, MINI-w38v-fcq9-pxc9, UBUNTU-CVE-2026-34826

## What is CVE-2026-34826?

CVE-2026-34826 is a medium-severity denial of service vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Utils.get_byte_ranges parses the HTTP Range header without limiting the number of individual byte ranges. Although the existing fix for CVE-2024-26141 rejects ranges whose total byte coverage exceeds the file size, it does not restrict the count of ranges. An attacker can supply many small overlapping ranges such as 0-0,0-0,0-0,... to trigger disproportionate CPU, memory, I/O, and bandwidth consumption per request. This results in a denial of service condition in Rack file-serving paths that process multipart byte range responses. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-34826?

6 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.2.23 |
| `rack` | RubyGems | All versions | 2.2.23 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |

Products: Rack Rack.

## How do I fix CVE-2026-34826?

Upgrade rack to a fixed version for your release line: 2.2.23, 3.1.21 or 3.2.6.

## Is CVE-2026-34826 being exploited?

There is no known exploitation of CVE-2026-34826 in the wild and no public exploit code.

## Other vulnerabilities in rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34826 and fix it if it is affected.

What it is: CVE-2026-34826 is a medium-severity denial of service vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34826 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.2.23
- rack (RubyGems): affected all versions; fixed in 2.2.23
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34826/ (Markdown: https://insights.sbomify.com/CVE-2026-34826/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34826
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34826
- OSV: https://osv.dev/vulnerability/CVE-2026-34826

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34826/
Summaries are generated and may contain mistakes; the official description above is the record.
