# CVE-2026-34827: Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser

> An unauthenticated attacker can cause denial of service in Rack applications by sending crafted multipart requests with excessive escape characters.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-34827, GHSA-v6x5-cg8r-vv6x, MINI-2p3f-vf25-hhhr, MINI-3j44-59wr-25h4, MINI-44r8-m2m6-hc35, MINI-4fhq-53gq-9q32, MINI-525v-42g3-hj5g, MINI-6725-2jhj-42h5, MINI-9fhq-v6fv-8435, MINI-gg37-rgxp-cjxm, MINI-vcm4-f6w7-cp65, MINI-wfwh-cj62-2pmw, MINI-xp8w-2hg7-5vf3, UBUNTU-CVE-2026-34827

## What is CVE-2026-34827?

CVE-2026-34827 is a high-severity denial of service vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. From versions 3.0.0.beta1 to before 3.1.21, and 3.2.0 to before 3.2.6, Rack::Multipart::Parser#handle_mime_head parses quoted multipart parameters such as Content-Disposition: form-data; name="..." using repeated String#index searches combined with String#slice! prefix deletion. For escape-heavy quoted values, this causes super-linear processing. An unauthenticated attacker can send a crafted multipart/form-data request containing many parts with long backslash-escaped parameter values to trigger excessive CPU usage during multipart parsing. This results in a denial of service condition in Rack applications that accept multipart form data. This issue has been patched in versions 3.1.21 and 3.2.6.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-407 (Inefficient Algorithmic Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-34827?

4 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |

Products: Rack Rack.

## How do I fix CVE-2026-34827?

Upgrade rack to a fixed version for your release line: 3.1.21 or 3.2.6.

## Is CVE-2026-34827 being exploited?

There is no known exploitation of CVE-2026-34827 in the wild and no public exploit code.

## Other vulnerabilities in rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)
- [CVE-2025-61770](https://insights.sbomify.com/CVE-2025-61770/): Rack's unbounded multipart preamble buffering enables DoS (memory exhaustion) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34827 and fix it if it is affected.

What it is: CVE-2026-34827 is a high-severity denial of service vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34827 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34827/ (Markdown: https://insights.sbomify.com/CVE-2026-34827/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34827
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34827
- OSV: https://osv.dev/vulnerability/CVE-2026-34827

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34827/
Summaries are generated and may contain mistakes; the official description above is the record.
