# CVE-2026-34828: listmonk: Active sessions remain valid after password reset and password change

> Attackers with stolen session cookies retain access after password changes, bypassing session invalidation in listmonk.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 3 Apr 2026
- **Also known as:** GHSA-h5j9-cvrw-v5qh, GO-2026-5414

## What is CVE-2026-34828?

CVE-2026-34828 is a high-severity vulnerability in knadh listmonk, published on 2 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

listmonk is a standalone, self-hosted, newsletter and mailing list manager. From version 4.1.0 to before version 6.1.0, a session management vulnerability allows previously issued authenticated sessions to remain valid after sensitive account security changes, specifically password reset and password change. As a result, an attacker who has already obtained a valid session cookie can retain access to the account even after the victim changes or resets their password. This weakens account recovery and session security guarantees. This issue has been patched in version 6.1.0.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-34828?

3 open source packages ship an affected version, including github.com/knadh/listmonk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/knadh/listmonk` | Go | From 1.1.1-0.20241028090858-319053dd7a90 | 1.1.1-0.20260329113754-1b5e8d38c778 |
| `github.com/knadh/listmonk` | Go | From 1.1.1-0.20241028090858-319053dd7a90 | 1.1.1-0.20260329113754-1b5e8d38c778 |
| `github.com/knadh/listmonk` | Go | From 1.1.1-0.20241028090858-319053dd7a90 | 1.1.1-0.20260329113754-1b5e8d38c778 |

Products: Nadh Listmonk.

## How do I fix CVE-2026-34828?

Upgrade github.com/knadh/listmonk to 1.1.1-0.20260329113754-1b5e8d38c778 or later.

## Is CVE-2026-34828 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34828 exists.

Public exploit code:

- listmonk’s Session Persistence After Password Reset and Password Change (github_poc): https://github.com/0xmrma/CVE-2026-34828

## Other vulnerabilities in knadh listmonk

- [CVE-2025-49136](https://insights.sbomify.com/CVE-2025-49136/): listmonk's Sprig template Injection vulnerability leads to reading of Environment Variable for low privilege user (critical 9.1)
- [CVE-2025-58430](https://insights.sbomify.com/CVE-2025-58430/): listmonk Vulnerable to CSRF to XSS Chain That Can Lead to Admin Account Takeover (high 8.6)
- [CVE-2025-46011](https://insights.sbomify.com/CVE-2025-46011/): SQL injection in n/a (medium 6.5)
- [CVE-2026-34584](https://insights.sbomify.com/CVE-2026-34584/): listmonk: Broken Access Control in CSV Import (Unauthorized List Assignment) (medium 5.4)
- [CVE-2026-21483](https://insights.sbomify.com/CVE-2026-21483/): listmonk Vulnerable to Stored XSS Leading to Admin Account Takeover (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34828 and fix it if it is affected.

What it is: CVE-2026-34828 is a high-severity vulnerability in knadh listmonk, published on 2 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34828 exists.

Affected packages and fixed versions:
- github.com/knadh/listmonk (Go): affected from 1.1.1-0.20241028090858-319053dd7a90; fixed in 1.1.1-0.20260329113754-1b5e8d38c778
- github.com/knadh/listmonk (Go): affected from 1.1.1-0.20241028090858-319053dd7a90; fixed in 1.1.1-0.20260329113754-1b5e8d38c778
- github.com/knadh/listmonk (Go): affected from 1.1.1-0.20241028090858-319053dd7a90; fixed in 1.1.1-0.20260329113754-1b5e8d38c778

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34828/ (Markdown: https://insights.sbomify.com/CVE-2026-34828/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34828
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34828
- OSV: https://osv.dev/vulnerability/CVE-2026-34828

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34828/
Summaries are generated and may contain mistakes; the official description above is the record.
