# CVE-2026-34829: Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length

> An unauthenticated attacker can cause denial of service by streaming unbounded multipart file uploads without Content-Length headers, exhausting disk space.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-34829, GHSA-8vqr-qjwx-82mw, MINI-39rc-69xv-8x4r, MINI-3mf8-x6mr-4pcr, MINI-3r7p-6gcw-gww5, MINI-5882-7pjf-25jc, MINI-6hpx-pvpc-q35p, MINI-84p3-8h53-jpgr, MINI-865r-x7h2-prm2, MINI-8xq5-hwhp-3x4m, MINI-9v84-xh38-cr4f, MINI-cc67-68gp-8c7r, MINI-fjp8-qcwc-mjjg, MINI-fwwv-57w7-xr53, MINI-hc57-886m-x594, MINI-j7m7-g2m6-6g75, MINI-jpj2-c292-xxrr, MINI-m3xv-hrm7-59qw, MINI-m54c-wxg5-5vx8, MINI-p9fg-629x-3324, MINI-r364-c3f4-3x85, MINI-rww3-jw8j-cffm, MINI-w84j-6r6c-hr4q, MINI-ww83-fqmv-m3q5, MINI-x6f9-8x83-p4qp, MINI-x9rx-3v6c-9682, UBUNTU-CVE-2026-34829

## What is CVE-2026-34829?

CVE-2026-34829 is a high-severity denial of service vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Multipart::Parser only wraps the request body in a BoundedIO when CONTENT_LENGTH is present. When a multipart/form-data request is sent without a Content-Length header, such as with HTTP chunked transfer encoding, multipart parsing continues until end-of-stream with no total size limit. For file parts, the uploaded body is written directly to a temporary file on disk rather than being constrained by the buffered in-memory upload limit. An unauthenticated attacker can therefore stream an arbitrarily large multipart file upload and consume unbounded disk space. This results in a denial of service condition for Rack applications that accept multipart form data. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-34829?

6 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.2.23 |
| `rack` | RubyGems | All versions | 2.2.23 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |

Products: Rack Rack.

## How do I fix CVE-2026-34829?

Upgrade rack to a fixed version for your release line: 2.2.23, 3.1.21 or 3.2.6.

## Is CVE-2026-34829 being exploited?

There is no known exploitation of CVE-2026-34829 in the wild and no public exploit code.

## Other vulnerabilities in rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)
- [CVE-2025-61770](https://insights.sbomify.com/CVE-2025-61770/): Rack's unbounded multipart preamble buffering enables DoS (memory exhaustion) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34829 and fix it if it is affected.

What it is: CVE-2026-34829 is a high-severity denial of service vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34829 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.2.23
- rack (RubyGems): affected all versions; fixed in 2.2.23
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34829/ (Markdown: https://insights.sbomify.com/CVE-2026-34829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34829
- OSV: https://osv.dev/vulnerability/CVE-2026-34829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34829/
Summaries are generated and may contain mistakes; the official description above is the record.
