# CVE-2026-34830: Rack: Rack::Sendfile regex injection via HTTP_X_ACCEL_MAPPING header allows arbitrary file reads through nginx

> Attackers can inject regex metacharacters via HTTP headers to bypass file restrictions and read arbitrary files from nginx internal locations.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 2 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-34830, GHSA-qv7j-4883-hwh7, MINI-2v26-hfm2-jc48, MINI-2x9j-83v7-439j, MINI-48p3-8q98-w6qq, MINI-4rqm-rwgw-ggc2, MINI-5848-6vvv-xw6j, MINI-8jr8-vqjx-6fg9, MINI-8wf6-xcf6-2w2q, MINI-c93v-9prj-jmwx, MINI-cwgc-p975-3fcr, MINI-f28v-3w79-w2h7, MINI-ghpp-cjmm-7cvv, MINI-hg24-f6hv-hh45, MINI-hj7f-phhr-hg9m, MINI-jx26-2whc-5qjh, MINI-q658-256m-6q83, MINI-q8jj-h7ch-qmvv, MINI-qm29-p4vq-wgjp, MINI-r9xf-77c9-qxqw, MINI-v5v9-wg7c-vfx3, MINI-v64q-p487-rwvf, MINI-v7w5-wqw7-v6hv, MINI-w62c-9rp2-239f, MINI-wg78-6j5g-p75v, MINI-xmwv-34p7-cgmx, UBUNTU-CVE-2026-34830

## What is CVE-2026-34830?

CVE-2026-34830 is a medium-severity path traversal vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Sendfile#map_accel_path interpolates the value of the X-Accel-Mapping request header directly into a regular expression when rewriting file paths for X-Accel-Redirect. Because the header value is not escaped, an attacker who can supply X-Accel-Mapping to the backend can inject regex metacharacters and control the generated X-Accel-Redirect response header. In deployments using Rack::Sendfile with x-accel-redirect, this can allow an attacker to cause nginx to serve unintended files from configured internal locations. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.

Weakness: CWE-625 (Permissive Regular Expression)

## Which versions are affected by CVE-2026-34830?

6 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.2.23 |
| `rack` | RubyGems | All versions | 2.2.23 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |

Products: Rack Rack.

## How do I fix CVE-2026-34830?

Upgrade rack to a fixed version for your release line: 2.2.23, 3.1.21 or 3.2.6.

## Is CVE-2026-34830 being exploited?

There is no known exploitation of CVE-2026-34830 in the wild and no public exploit code.

## Other vulnerabilities in rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34830 and fix it if it is affected.

What it is: CVE-2026-34830 is a medium-severity path traversal vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34830 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.2.23
- rack (RubyGems): affected all versions; fixed in 2.2.23
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34830/ (Markdown: https://insights.sbomify.com/CVE-2026-34830/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34830
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34830
- OSV: https://osv.dev/vulnerability/CVE-2026-34830

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34830/
Summaries are generated and may contain mistakes; the official description above is the record.
