# CVE-2026-34831: Rack: Content-Length mismatch in Rack::Files error responses

> An attacker can cause HTTP response desynchronization in Rack::Files by exploiting a Content-Length mismatch with multibyte UTF-8 characters in 404 responses.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 3 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-34831, GHSA-q2ww-5357-x388, MINI-23x3-g4pr-hqx5, MINI-2vjr-2xj3-mp4g, MINI-373h-wh2v-6f8v, MINI-3vvp-422v-m53w, MINI-4fmr-pvhv-jw5w, MINI-6947-f25v-fq69, MINI-8jmc-7r46-9vp2, MINI-92gj-23rf-2pc6, MINI-f57v-92gx-fhqp, MINI-g4hg-r4mc-764p, MINI-mpxp-j4q8-8qm2, MINI-pfh4-5878-5fhj, MINI-pvv5-qwmr-83c2, MINI-px74-cjmj-frcq, MINI-qxxh-259f-3x2g, MINI-rfq3-f8h8-qcqc, MINI-rpvq-3x2x-mp7j, MINI-v2g5-47f4-9x65, MINI-v54w-fvgp-7hmx, MINI-vqw3-c26g-vxmh, MINI-w44m-9hfc-43wf, MINI-whh5-246c-r95c, MINI-x3xr-qqqr-4j4r, MINI-xvp4-cwjw-2v76, UBUNTU-CVE-2026-34831

## What is CVE-2026-34831?

CVE-2026-34831 is a medium-severity vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Files#fail sets the Content-Length response header using String#size instead of String#bytesize. When the response body contains multibyte UTF-8 characters, the declared Content-Length is smaller than the number of bytes actually sent on the wire. Because Rack::Files reflects the requested path in 404 responses, an attacker can trigger this mismatch by requesting a non-existent path containing percent-encoded UTF-8 characters. This results in incorrect HTTP response framing and may cause response desynchronization in deployments that rely on the incorrect Content-Length value. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.

Weakness: CWE-135 (Incorrect Calculation of Multi-Byte String Length), CWE-130 (Improper Handling of Length Parameter Inconsistency)

## Which versions are affected by CVE-2026-34831?

6 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.2.23 |
| `rack` | RubyGems | All versions | 2.2.23 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |

Products: Rack Rack.

## How do I fix CVE-2026-34831?

Upgrade rack to a fixed version for your release line: 2.2.23, 3.1.21 or 3.2.6.

## Is CVE-2026-34831 being exploited?

There is no known exploitation of CVE-2026-34831 in the wild and no public exploit code.

## Other vulnerabilities in rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34831 and fix it if it is affected.

What it is: CVE-2026-34831 is a medium-severity vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34831 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.2.23
- rack (RubyGems): affected all versions; fixed in 2.2.23
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34831/ (Markdown: https://insights.sbomify.com/CVE-2026-34831/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34831
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34831
- OSV: https://osv.dev/vulnerability/CVE-2026-34831

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34831/
Summaries are generated and may contain mistakes; the official description above is the record.
