# CVE-2026-34835: Rack: `Rack::Request` accepts invalid Host characters, enabling host allowlist bypass.

> Attackers can bypass host allowlists in Rack applications by sending invalid Host header characters, potentially enabling host header poisoning.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 2 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-34835, GHSA-g2pf-xv49-m2h5, MINI-2wff-rm7x-5hhg, MINI-2x4c-p5cr-7823, MINI-522x-4979-h862, MINI-5jgj-hqwr-mr89, MINI-c78r-gmcp-8jg2, MINI-fxmj-rmp7-gw8q, MINI-gq8r-2hf7-9q77, MINI-pfq4-7ghw-xf4m, MINI-pm4q-29rm-x2vc, MINI-rfg4-7hqj-6mwx, MINI-xfmq-xc9c-v4wf, UBUNTU-CVE-2026-34835

## What is CVE-2026-34835?

CVE-2026-34835 is a medium-severity vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. From versions 3.0.0.beta1 to before 3.1.21, and 3.2.0 to before 3.2.6, Rack::Request parses the Host header using an AUTHORITY regular expression that accepts characters not permitted in RFC-compliant hostnames, including /, ?, #, and @. Because req.host returns the full parsed value, applications that validate hosts using naive prefix or suffix checks can be bypassed. This can lead to host header poisoning in applications that use req.host, req.url, or req.base_url for link generation, redirects, or origin validation. This issue has been patched in versions 3.1.21 and 3.2.6.

Weakness: CWE-1286 (Improper Validation of Syntactic Correctness of Input)

## Which versions are affected by CVE-2026-34835?

4 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.21 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |
| `rack` | RubyGems | From 3.2.0 | 3.2.6 |

Products: Rack Rack.

## How do I fix CVE-2026-34835?

Upgrade rack to a fixed version for your release line: 3.1.21 or 3.2.6.

## Is CVE-2026-34835 being exploited?

There is no known exploitation of CVE-2026-34835 in the wild and no public exploit code.

Public exploit code:

- A black-box (DAST) security analysis of CVE-2026-34835 focusing on external validation methodology, observable behavior, security impact, and defensive recommendations. (github_poc): https://github.com/Cyber-note/CVE-2026-34835-Black-box-Analysis

## Other vulnerabilities in rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34835 and fix it if it is affected.

What it is: CVE-2026-34835 is a medium-severity vulnerability in rack, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34835 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.21
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34835/ (Markdown: https://insights.sbomify.com/CVE-2026-34835/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34835
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34835
- OSV: https://osv.dev/vulnerability/CVE-2026-34835

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34835/
Summaries are generated and may contain mistakes; the official description above is the record.
