# CVE-2026-34839: Glances Vulnerable to Cross-Origin Information Disclosure via Unauthenticated REST API (/api/4) due to Permissive CORS

> A malicious website can read sensitive system information from a running Glances instance via its unauthenticated REST API due to permissive CORS settings.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Apr 2026
- **Updated:** 21 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-34839, GHSA-gfc2-9qmw-w7vh, PYSEC-2026-2175, UBUNTU-CVE-2026-34839

## What is CVE-2026-34839?

CVE-2026-34839 is a high-severity vulnerability in nicolargo glances, published on 20 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Glances is an open-source system cross-platform monitoring tool. Prior to version 4.5.4, the Glances web server exposes a REST API (`/api/4/*`) that is accessible without authentication and allows cross-origin requests from any origin due to a permissive CORS policy (`Access-Control-Allow-Origin: *`). This allows a malicious website to read sensitive system information from a running Glances instance in the victim’s browser, leading to cross-origin data exfiltration. While a previous advisory exists for XML-RPC CORS issues, this report demonstrates that the REST API (`/api/4/*`) is also affected and exposes significantly more sensitive data. Version 4.5.4 patches the issue.

Weakness: CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains), CWE-306 (Missing Authentication for Critical Functionality), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-34839?

3 open source packages ship an affected version, including glances and Glances. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glances` | PyPI | All versions | 4.5.4 |
| `glances` | PyPI | All versions | 4.5.4 |
| `Glances` | PyPI | All versions | 4.5.4 |

Products: Nicolargo Glances.

## How do I fix CVE-2026-34839?

Upgrade glances to 4.5.4 or later.

## Is CVE-2026-34839 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34839 exists.

## Other vulnerabilities in nicolargo glances

- [CVE-2026-32633](https://insights.sbomify.com/CVE-2026-32633/): Glances's Browser API Exposes Reusable Downstream Credentials via `/api/4/serverslist` (critical 9.1)
- [CVE-2026-32596](https://insights.sbomify.com/CVE-2026-32596/): Glances exposes the REST API without authentication (high 8.7)
- [CVE-2026-30928](https://insights.sbomify.com/CVE-2026-30928/): Glances Exposes Unauthenticated Configuration Secrets (high 8.7)
- [CVE-2026-32610](https://insights.sbomify.com/CVE-2026-32610/): Glances's Default CORS Configuration Allows Cross-Origin Credential Theft (high 8.1)
- [CVE-2026-32634](https://insights.sbomify.com/CVE-2026-32634/): Glances Central Browser Autodiscovery Leaks Reusable Credentials to Zeroconf-Spoofed Servers (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34839 and fix it if it is affected.

What it is: CVE-2026-34839 is a high-severity vulnerability in nicolargo glances, published on 20 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34839 exists.

Affected packages and fixed versions:
- glances (PyPI): affected all versions; fixed in 4.5.4
- glances (PyPI): affected all versions; fixed in 4.5.4
- Glances (PyPI): affected all versions; fixed in 4.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34839/ (Markdown: https://insights.sbomify.com/CVE-2026-34839/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34839
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34839
- OSV: https://osv.dev/vulnerability/CVE-2026-34839

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34839/
Summaries are generated and may contain mistakes; the official description above is the record.
