# CVE-2026-34881: OpenStack Glance is affected by Server-Side Request Forgery (SSRF)

> Authenticated users can bypass URL validation via HTTP redirects in image import to access internal services, requiring an upgrade to OpenStack Glance.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2026
- **Updated:** 14 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-34881, GHSA-mc26-q38v-83gv, PYSEC-2026-2492, RHSA-2026:39812, UBUNTU-CVE-2026-34881

## What is CVE-2026-34881?

CVE-2026-34881 is a medium-severity server-side request forgery vulnerability in OpenStack Glance, published on 31 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenStack Glance before 29.1.1, 30.x before 30.1.1, and 31.0.0 is affected by Server-Side Request Forgery (SSRF). By use of HTTP redirects, an authenticated user can bypass URL validation checks and redirect to internal services. Only glance image import functionality is affected. In particular, the web-download and glance-download import methods are subject to this vulnerability, as is the optional (not enabled by default) ovf_process image import plugin.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-34881?

7 open source packages ship an affected version, including glance. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glance` | PyPI | All versions | 29.2.0, 30.2.0, 31.1.0 |
| `glance` | PyPI | All versions | 29.2.0 |
| `glance` | PyPI | All versions | 29.2.0 |
| `glance` | PyPI | From 30.0.0 | 30.2.0 |
| `glance` | PyPI | From 30.0.0 | 30.2.0 |
| `glance` | PyPI | From 31.0.0 | 31.1.0 |
| `glance` | PyPI | From 31.0.0 | 31.1.0 |
| `openstack-glance` | Red Hat:openstack:18.0::el9 | All versions | 1:26.1.1-18.0.20260422134725.c2ac316.el9ost |
| `python3-glance` | Red Hat:openstack:18.0::el9 | All versions | 1:26.1.1-18.0.20260422134725.c2ac316.el9ost |

Products: Openstack Glance.

## How do I fix CVE-2026-34881?

Upgrade glance to a fixed version for your release line: 29.2.0, 30.2.0 or 31.1.0.

## Is CVE-2026-34881 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34881 exists.

## Other vulnerabilities in OpenStack Glance

- [CVE-2017-7200](https://insights.sbomify.com/CVE-2017-7200/): OpenStack Glance Server-Side Request Forgery (SSRF) (medium 5.8)
- [CVE-2015-8234](https://insights.sbomify.com/CVE-2015-8234/): OpenStack Glance Signature Verification Bypass (medium 5.5)
- [CVE-2016-8611](https://insights.sbomify.com/CVE-2016-8611/): Denial of service in openstack-glance (medium 4.3)
- [CVE-2015-3289](https://insights.sbomify.com/CVE-2015-3289/): Denial of service in n/a (medium 4.0)
- [CVE-2015-5163](https://insights.sbomify.com/CVE-2015-5163/): OpenStack Image Service (Glance) allows remote authenticated users to read arbitrary file (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34881 and fix it if it is affected.

What it is: CVE-2026-34881 is a medium-severity server-side request forgery vulnerability in OpenStack Glance, published on 31 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34881 exists.

Affected packages and fixed versions:
- glance (PyPI): affected all versions; fixed in 29.2.0, 30.2.0, 31.1.0
- glance (PyPI): affected all versions; fixed in 29.2.0
- glance (PyPI): affected all versions; fixed in 29.2.0
- glance (PyPI): affected from 30.0.0; fixed in 30.2.0
- glance (PyPI): affected from 30.0.0; fixed in 30.2.0
- glance (PyPI): affected from 31.0.0; fixed in 31.1.0
- glance (PyPI): affected from 31.0.0; fixed in 31.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34881/ (Markdown: https://insights.sbomify.com/CVE-2026-34881/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34881
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34881
- OSV: https://osv.dev/vulnerability/CVE-2026-34881

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34881/
Summaries are generated and may contain mistakes; the official description above is the record.
