CVE-2026-3494 MariaDB Server Audit Plugin Comment Handling Bypass
Authenticated users can bypass audit logging for specific SQL statements by using comment prefixes, hiding activity from administrators.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-3494?
CVE-2026-3494 is a medium-severity vulnerability in Mariadb Mariadb, published on 3 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In MariaDB server version through 11.8.5, when server audit plugin is enabled with server_audit_events variable configured with QUERY_DCL, QUERY_DDL, or QUERY_DML filtering, if an authenticated database user invokes a SQL statement prefixed with double-hyphen (—) or hash (#) style comments, the statement is not logged.
Weakness: CWE-778
Which versions are affected by CVE-2026-3494?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | All versions | 10.6.25, 10.11.16, 11.4.10, 11.8.6 |
mariadb-min Bitnami | All versions | 10.6.25, 10.11.16, 11.4.10, 11.8.6 |
mysql-client Bitnami | All versions | 10.6.25, 10.11.18, 12.0.2 |
Products include Amazon Aurora Mysql, Amazon Relational Database Service, Mariadb Mariadb.
How do I fix CVE-2026-3494?
Upgrade mariadb to a fixed version for your release line: 10.6.25, 10.11.16, 11.4.10 or 11.8.6.
Is CVE-2026-3494 being exploited?
There is no known exploitation of CVE-2026-3494 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as ALPINE-CVE-2026-3494, AZL-79365, AZL-79550, BELL-CVE-2026-3494, BIT-mariadb-2026-3494, BIT-mariadb-min-2026-3494 and 15 more.