CVE-2026-34942 Wasmtime panics when transcoding misaligned utf-16 strings

Medium 5.9 Published Updated

A malicious WebAssembly guest can trigger a host panic in Wasmtime by sending misaligned UTF-16 strings, causing a denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-34942?

CVE-2026-34942 is a medium-severity denial of service vulnerability in bytecodealliance wasmtime, published on 9 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Wasmtime is a runtime for WebAssembly. Prior to 24.0.7, 36.0.7, 42.0.2, and 43.0.1, Wasmtime's implementation of transcoding strings into the Component Model's utf16 or latin1+utf16 encodings improperly verified the alignment of reallocated strings. This meant that unaligned pointers could be passed to the host for transcoding which would trigger a host panic. This panic is possible to trigger from malicious guests which transfer very specific strings across components with specific addresses. Host panics are considered a DoS vector in Wasmtime as the panic conditions are controlled by the guest in this situation. This vulnerability is fixed in 24.0.7, 36.0.7, 42.0.2, and 43.0.1.

Weakness: CWE-129

Which versions are affected by CVE-2026-34942?

9 open source packages ship an affected version, including wasmtime. It affects 1 product.

PackageAffectedFixed in
wasmtime crates.ioAll versions24.0.7
wasmtime crates.ioAll versions24.0.7
wasmtime crates.ioFrom 0.0.0-024.0.7, 36.0.7, 42.0.2, 43.0.1
wasmtime crates.ioFrom 25.0.036.0.7
wasmtime crates.ioFrom 25.0.036.0.7
wasmtime crates.ioFrom 37.0.042.0.2
3 more packages
wasmtime crates.ioFrom 37.0.042.0.2
wasmtime crates.ioFrom 43.0.043.0.1
wasmtime crates.ioFrom 43.0.043.0.1

Products include Bytecodealliance Wasmtime.

How do I fix CVE-2026-34942?

Upgrade wasmtime to a fixed version for your release line: 24.0.7, 36.0.7, 42.0.2 or 43.0.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-34942 being exploited?

There is no known exploitation of CVE-2026-34942 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-34942, GHSA-jxhv-7h78-9775, JLSEC-2026-1355, RUSTSEC-2026-0092, UBUNTU-CVE-2026-34942.

Is CVE-2026-34942 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free