# CVE-2026-34942: Wasmtime panics when transcoding misaligned utf-16 strings

> A malicious WebAssembly guest can trigger a host panic in Wasmtime by sending misaligned UTF-16 strings, causing a denial of service.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 9 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-34942, GHSA-jxhv-7h78-9775, JLSEC-2026-1355, RUSTSEC-2026-0092, UBUNTU-CVE-2026-34942

## What is CVE-2026-34942?

CVE-2026-34942 is a medium-severity denial of service vulnerability in bytecodealliance wasmtime, published on 9 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Wasmtime is a runtime for WebAssembly. Prior to 24.0.7, 36.0.7, 42.0.2, and 43.0.1, Wasmtime's implementation of transcoding strings into the Component Model's utf16 or latin1+utf16 encodings improperly verified the alignment of reallocated strings. This meant that unaligned pointers could be passed to the host for transcoding which would trigger a host panic. This panic is possible to trigger from malicious guests which transfer very specific strings across components with specific addresses. Host panics are considered a DoS vector in Wasmtime as the panic conditions are controlled by the guest in this situation. This vulnerability is fixed in 24.0.7, 36.0.7, 42.0.2, and 43.0.1.

Weakness: CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-34942?

9 open source packages ship an affected version, including wasmtime. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wasmtime` | crates.io | All versions | 24.0.7 |
| `wasmtime` | crates.io | All versions | 24.0.7 |
| `wasmtime` | crates.io | From 0.0.0-0 | 24.0.7, 36.0.7, 42.0.2, 43.0.1 |
| `wasmtime` | crates.io | From 25.0.0 | 36.0.7 |
| `wasmtime` | crates.io | From 25.0.0 | 36.0.7 |
| `wasmtime` | crates.io | From 37.0.0 | 42.0.2 |
| `wasmtime` | crates.io | From 37.0.0 | 42.0.2 |
| `wasmtime` | crates.io | From 43.0.0 | 43.0.1 |
| `wasmtime` | crates.io | From 43.0.0 | 43.0.1 |

Products: Bytecodealliance Wasmtime.

## How do I fix CVE-2026-34942?

Upgrade wasmtime to a fixed version for your release line: 24.0.7, 36.0.7, 42.0.2 or 43.0.1.

## Is CVE-2026-34942 being exploited?

There is no known exploitation of CVE-2026-34942 in the wild and no public exploit code.

## Other vulnerabilities in bytecodealliance wasmtime

- [CVE-2026-34971](https://insights.sbomify.com/CVE-2026-34971/): Wasmtime miscompiled guest heap access enables sandbox escape on aarch64 Cranelift (critical 9.0)
- [CVE-2026-34987](https://insights.sbomify.com/CVE-2026-34987/): Wasmtime with Winch compiler backend on aarch64 may allow a sandbox-escaping memory access (critical 9.0)
- [CVE-2022-39393](https://insights.sbomify.com/CVE-2022-39393/): Wasmtime vulnerable to data leakage between instances in the pooling allocator (high 8.6)
- [CVE-2022-24791](https://insights.sbomify.com/CVE-2022-24791/): Use after free in Wasmtime (high 8.1)
- [CVE-2026-47261](https://insights.sbomify.com/CVE-2026-47261/): Wasmtime: WASI path_open(TRUNCATE) bypasses `FilePerms::WRITE` host restriction (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34942 and fix it if it is affected.

What it is: CVE-2026-34942 is a medium-severity denial of service vulnerability in bytecodealliance wasmtime, published on 9 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-34942 in the wild and no public exploit code.

Affected packages and fixed versions:
- wasmtime (crates.io): affected all versions; fixed in 24.0.7
- wasmtime (crates.io): affected all versions; fixed in 24.0.7
- wasmtime (crates.io): affected from 0.0.0-0; fixed in 24.0.7, 36.0.7, 42.0.2, 43.0.1
- wasmtime (crates.io): affected from 25.0.0; fixed in 36.0.7
- wasmtime (crates.io): affected from 25.0.0; fixed in 36.0.7
- wasmtime (crates.io): affected from 37.0.0; fixed in 42.0.2
- wasmtime (crates.io): affected from 37.0.0; fixed in 42.0.2
- wasmtime (crates.io): affected from 43.0.0; fixed in 43.0.1
- wasmtime (crates.io): affected from 43.0.0; fixed in 43.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34942/ (Markdown: https://insights.sbomify.com/CVE-2026-34942/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34942
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34942
- OSV: https://osv.dev/vulnerability/CVE-2026-34942

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34942/
Summaries are generated and may contain mistakes; the official description above is the record.
