CVE-2026-34943 Wasmtime panics when lifting `flags` component value

Medium 5.6 Published Updated

A guest-controlled panic in Wasmtime when lifting flags values allows attackers to cause a denial of service against the host runtime.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-34943?

CVE-2026-34943 is a medium-severity denial of service vulnerability in bytecodealliance wasmtime, published on 9 Apr 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Wasmtime is a runtime for WebAssembly. Prior to 24.0.7, 36.0.7, 42.0.2, and 43.0.1, Wasmtime contains a possible panic which can happen when a flags-typed component model value is lifted with the Val type. If bits are set outside of the set of flags the component model specifies that these bits should be ignored but Wasmtime will panic when this value is lifted. This panic only affects wasmtime's implementation of lifting into Val, not when using the flags! macro. This additionally only affects flags-typed values which are part of a WIT interface. This has the risk of being a guest-controlled panic within the host which Wasmtime considers a DoS vector. This vulnerability is fixed in 24.0.7, 36.0.7, 42.0.2, and 43.0.1.

Weakness: CWE-248

Which versions are affected by CVE-2026-34943?

9 open source packages ship an affected version, including wasmtime. It affects 1 product.

PackageAffectedFixed in
wasmtime crates.ioAll versions24.0.7
wasmtime crates.ioAll versions24.0.7
wasmtime crates.ioFrom 0.0.0-024.0.7, 36.0.7, 42.0.2, 43.0.1
wasmtime crates.ioFrom 25.0.036.0.7
wasmtime crates.ioFrom 25.0.036.0.7
wasmtime crates.ioFrom 37.0.042.0.2
3 more packages
wasmtime crates.ioFrom 37.0.042.0.2
wasmtime crates.ioFrom 43.0.043.0.1
wasmtime crates.ioFrom 43.0.043.0.1

Products include Bytecodealliance Wasmtime.

How do I fix CVE-2026-34943?

Upgrade wasmtime to a fixed version for your release line: 24.0.7, 36.0.7, 42.0.2 or 43.0.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-34943 being exploited?

There is no known exploitation of CVE-2026-34943 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-34943, GHSA-m758-wjhj-p3jq, JLSEC-2026-1356, RUSTSEC-2026-0085, UBUNTU-CVE-2026-34943.

Is CVE-2026-34943 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free