CVE-2026-3495 Unescaped variables during error page composition
An attacker with site configuration edit access can inject malicious JavaScript into error pages, potentially executing code or taking over accounts.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-3495?
CVE-2026-3495 is a low-severity cross-site scripting vulnerability in Mattermost Mattermost Server, published on 18 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13 fail to escape some variables that could contain malicious content during error page composition which allows an attacker with access to edit some site configuration to execute some malicious code via injecting some JS as part of those values.. Mattermost Advisory ID: MMSA-2026-00622
Weakness: CWE-79
Which versions are affected by CVE-2026-3495?
12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260310115442-5a1ea95044d |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260310115442-5a1ea95044d |
github.com/mattermost/mattermost/server/v8 Go | From 10.11.0 | 10.11.14 |
github.com/mattermost/mattermost/server/v8 Go | From 10.11.0 | 10.11.14 |
github.com/mattermost/mattermost/server/v8 Go | From 11.5.0 | 11.5.2 |
6 more packages
github.com/mattermost/mattermost/server/v8 Go | From 11.5.0 | 11.5.2 |
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20260310115442-5a1ea95044dc |
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20260310115442-5a1ea95044dc |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.14+incompatible, 11.5.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-3495?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20260310115442-5a1ea95044d, 10.11.14 or 11.5.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-3495 being exploited?
There is no known exploitation of CVE-2026-3495 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-jx93-pf6x-874r, GO-2026-5484.