# CVE-2026-34972: OpenFGA's BatchCheck within-request deduplication produces incorrect authorization decisions via list-value cache-key collision

> Attackers can bypass authorization checks in OpenFGA by exploiting cache key collisions in BatchCheck, leading to incorrect permission grants.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** CLEANSTART-2026-ED95969, CLEANSTART-2026-SX02266, GHSA-jwvj-g8pc-cx45, GO-2026-5483, MINI-2q75-9w6m-gvjw, MINI-668m-4jv8-q77w, MINI-7rj9-c6j7-hhv5, MINI-7xw6-9v6v-v7c5, MINI-8786-9qqj-wp4h, MINI-8f64-j27p-r8c5, MINI-c3rw-pmh3-wx28, MINI-cpcf-xxrx-rw2q, MINI-f8jv-3925-x4jx, MINI-jmwj-j37g-chjp, MINI-m4xg-7jmp-54q9, MINI-mg7j-mpxm-wwr8, MINI-mhc9-633j-wq4j, MINI-pjm8-x99f-q9f2, MINI-r3pr-gfxq-m2m3, MINI-vfw9-4wfh-rhq9, MINI-x7x8-4gx6-gpfm, MINI-xhgj-fxvp-2x27

## What is CVE-2026-34972?

CVE-2026-34972 is a medium-severity vulnerability in openfga, published on 6 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. From 1.8.0 to 1.13.1, under specific conditions, BatchCheck calls with multiple checks sent for the same object, relation, and user combination can result in improper policy enforcement. This vulnerability is fixed in 1.14.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-34972?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | From 1.8.0 | 1.14.0 |
| `github.com/openfga/openfga` | Go | From 1.8.0 | 1.14.0 |
| `github.com/openfga/openfga` | Go | From 1.8.0 | 1.14.0 |

Products: Openfga Helm Charts, Openfga Openfga.

## How do I fix CVE-2026-34972?

Upgrade github.com/openfga/openfga to 1.14.0 or later.

## Is CVE-2026-34972 being exploited?

There is no known exploitation of CVE-2026-34972 in the wild and no public exploit code.

## Other vulnerabilities in openfga

- [CVE-2026-55689](https://insights.sbomify.com/CVE-2026-55689/): OpenFGA: OIDC audience validation skipped when --authn-oidc-audience is unset (medium 6.8)
- [CVE-2026-24851](https://insights.sbomify.com/CVE-2026-24851/): OpenFGA Improper Policy Enforcement (medium 5.8)
- [CVE-2025-64751](https://insights.sbomify.com/CVE-2025-64751/): OpenFGA Improper Policy Enforcement (medium 5.8)
- [CVE-2025-55213](https://insights.sbomify.com/CVE-2025-55213/): OpenFGA Authorization Bypass (Check) (medium 5.8)
- [CVE-2025-48371](https://insights.sbomify.com/CVE-2025-48371/): OpenFGA Authorization Bypass (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34972 and fix it if it is affected.

What it is: CVE-2026-34972 is a medium-severity vulnerability in openfga, published on 6 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34972 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected from 1.8.0; fixed in 1.14.0
- github.com/openfga/openfga (Go): affected from 1.8.0; fixed in 1.14.0
- github.com/openfga/openfga (Go): affected from 1.8.0; fixed in 1.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34972/ (Markdown: https://insights.sbomify.com/CVE-2026-34972/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34972
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34972
- OSV: https://osv.dev/vulnerability/CVE-2026-34972

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34972/
Summaries are generated and may contain mistakes; the official description above is the record.
