# CVE-2026-34989: CI4MS: Profile & User Management Full Account Takeover for All-Roles & Privilege-Escalation via Stored DOM XSS

> Attackers can inject malicious scripts via profile names to achieve full account takeover and privilege escalation in CI4MS.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** GHSA-vr2g-rhm5-q4jr

## What is CVE-2026-34989?

CVE-2026-34989 is a critical cross-site scripting vulnerability in ci4-cms-erp ci4ms, published on 6 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to 31.0.0.0, the application fails to properly sanitize user-controlled input when users update their profile name (e.g., full name / username). An attacker can inject a malicious JavaScript payload into their profile name, which is then stored server-side. This stored payload is later rendered unsafely in multiple application views without proper output encoding, leading to stored cross-site scripting (XSS). This vulnerability is fixed in 31.0.0.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-34989?

2 open source packages ship an affected version, including ci4-cms-erp/ci4ms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ci4-cms-erp/ci4ms` | Packagist | All versions | 31.0.0.0 |
| `ci4-cms-erp/ci4ms` | Packagist | All versions | 31.0.0.0 |

Products: Ci4-Cms-Erp Ci4ms.

## How do I fix CVE-2026-34989?

Upgrade ci4-cms-erp/ci4ms to 31.0.0.0 or later.

## Is CVE-2026-34989 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34989 exists.

## Other vulnerabilities in ci4-cms-erp ci4ms

- [CVE-2026-34569](https://insights.sbomify.com/CVE-2026-34569/): CI4MS: Blogs Categories Full Account Takeover for All-Roles & Privilege-Escalation via Stored DOM XSS (critical 10.0)
- [CVE-2026-34571](https://insights.sbomify.com/CVE-2026-34571/): CI4MS: Stored Cross‑Site Scripting (Stored XSS) in Backend User Management Allows Session Hijacking and Full Administrative Account Compromise (critical 10.0)
- [CVE-2026-25510](https://insights.sbomify.com/CVE-2026-25510/): CI4MS Vulnerable to Remote Code Execution (RCE) via Arbitrary File Creation and Save in File Editor (critical 10.0)
- [CVE-2026-34559](https://insights.sbomify.com/CVE-2026-34559/): CI4MS: Blogs Tags Full Account Takeover for All-Roles & Privilege-Escalation via Stored DOM XSS (critical 9.1)
- [CVE-2026-34560](https://insights.sbomify.com/CVE-2026-34560/): CI4MS: Logs Full Account Takeover for All-Roles & Privilege-Escalation via Stored DOM XSS (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34989 and fix it if it is affected.

What it is: CVE-2026-34989 is a critical cross-site scripting vulnerability in ci4-cms-erp ci4ms, published on 6 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-34989 exists.

Affected packages and fixed versions:
- ci4-cms-erp/ci4ms (Packagist): affected all versions; fixed in 31.0.0.0
- ci4-cms-erp/ci4ms (Packagist): affected all versions; fixed in 31.0.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34989/ (Markdown: https://insights.sbomify.com/CVE-2026-34989/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34989
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34989
- OSV: https://osv.dev/vulnerability/CVE-2026-34989

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34989/
Summaries are generated and may contain mistakes; the official description above is the record.
