# CVE-2026-34992: Missing Encryption of Sensitive Data in antrea.io/antrea

> Attackers can read sensitive IPv6 Pod traffic in plaintext in dual-stack Antrea clusters with IPsec enabled due to missing encryption.

- **Severity:** High 7.1 (`CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** GHSA-qcmw-8mm4-4p28, GO-2026-5579

## What is CVE-2026-34992?

CVE-2026-34992 is a high-severity vulnerability in antrea-io antrea, published on 6 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Antrea is a Kubernetes networking solution intended to be Kubernetes native. Prior to 2.4.5 and 2.5.2, a missing encryption vulnerability affects inter-Node Pod traffic. In Antrea clusters configured for dual-stack networking with IPsec encryption enabled (trafficEncryptionMode: ipsec), Antrea fails to apply encryption for IPv6 Pod traffic. While the IPv4 traffic is correctly encrypted via ESP (Encapsulating Security Payload), traffic using IPv6 is transmitted in plaintext. This occurs because the packets are encapsulated (using Geneve or VXLAN) but bypass the IPsec encryption layer. Impacted Users: users with dual-stack clusters and IPsec encryption enabled. Single-stack IPv4 or IPv6 clusters are not affected. This vulnerability is fixed in 2.4.5 and 2.5.2.

Weakness: CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2026-34992?

9 open source packages ship an affected version, including antrea.io/antrea. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `antrea.io/antrea` | Go | All versions | None |
| `antrea.io/antrea` | Go | All versions | 1.11.0-alpha.0.0.20260225185322-738bad662b20 |
| `antrea.io/antrea` | Go | All versions | 1.11.0-alpha.0.0.20260225185322-738bad662b20 |
| `antrea.io/antrea` | Go | All versions | 1.11.0-alpha.0.0.20260225185322-738bad662b20 |
| `antrea.io/antrea` | Go | From 1.11.0 | None |
| `antrea.io/antrea` | Go | From 1.11.0 | None |
| `antrea.io/antrea` | Go | From 1.11.0 | None |
| `antrea.io/antrea` | Go | From 2.5.0 | None |
| `antrea.io/antrea` | Go | From 2.5.0 | None |

Products: Linuxfoundation Antrea.

## How do I fix CVE-2026-34992?

Upgrade antrea.io/antrea to 1.11.0-alpha.0.0.20260225185322-738bad662b20 or later.

## Is CVE-2026-34992 being exploited?

There is no known exploitation of CVE-2026-34992 in the wild and no public exploit code.

## Other vulnerabilities in antrea-io antrea

- [CVE-2026-25804](https://insights.sbomify.com/CVE-2026-25804/): Antrea has invalid enforcement order for network policy rules caused by integer overflow (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34992 and fix it if it is affected.

What it is: CVE-2026-34992 is a high-severity vulnerability in antrea-io antrea, published on 6 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-34992 in the wild and no public exploit code.

Affected packages and fixed versions:
- antrea.io/antrea (Go): affected all versions; no fix listed
- antrea.io/antrea (Go): affected all versions; fixed in 1.11.0-alpha.0.0.20260225185322-738bad662b20
- antrea.io/antrea (Go): affected all versions; fixed in 1.11.0-alpha.0.0.20260225185322-738bad662b20
- antrea.io/antrea (Go): affected all versions; fixed in 1.11.0-alpha.0.0.20260225185322-738bad662b20
- antrea.io/antrea (Go): affected from 1.11.0; no fix listed
- antrea.io/antrea (Go): affected from 1.11.0; no fix listed
- antrea.io/antrea (Go): affected from 1.11.0; no fix listed
- antrea.io/antrea (Go): affected from 2.5.0; no fix listed
- antrea.io/antrea (Go): affected from 2.5.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34992/ (Markdown: https://insights.sbomify.com/CVE-2026-34992/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34992
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34992
- OSV: https://osv.dev/vulnerability/CVE-2026-34992

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34992/
Summaries are generated and may contain mistakes; the official description above is the record.
