# CVE-2026-34993: AIOHTTP Vulnerable to Deserialization of Untrusted Data

> Attackers can achieve arbitrary code execution if an application uses CookieJar.load() with untrusted input in aiohttp.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jun 2026
- **Updated:** 17 Sep 2026
- **Also known as:** AZL-89330, CLEANSTART-2026-HL56908, CLSA-2026-1789542238, CLSA-2026-1789638581, DEBIAN-CVE-2026-34993, ECHO-1919-21b7-3a3e, GHSA-jg22-mg44-37j8, MINI-2f95-phmr-v22c, MINI-2xpw-27gv-g9pv, MINI-35x7-x5w5-h4vx, MINI-5pvj-ph35-92qr, MINI-76fv-2425-fwr8, MINI-7cc6-jvm7-5696, MINI-7h8c-wvx9-vwwh, MINI-7p94-56qf-fr4c, MINI-85wv-52mc-5vfg, MINI-8p6g-8h58-pjh6, MINI-cgqq-47mw-5pv2, MINI-hw7f-h9q2-rvc4, MINI-mghf-8gh6-26v8, MINI-qhww-h44v-rcv8, MINI-r25j-fj79-p64h, MINI-x7r4-gr7c-j98c, PYSEC-2026-2104, ROOT-APP-PYPI-CVE-2026-34993, UBUNTU-CVE-2026-34993, openSUSE-SU-2026:10963-1

## What is CVE-2026-34993?

CVE-2026-34993 is a medium-severity unsafe deserialization vulnerability in aio-libs aiohttp, published on 2 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. Prior to version 3.14.0, using ``CookieJar.load()`` with untrusted input may allow arbitrary code execution. Most applications using this function will be doing so with the user's own data, so this is unlikely to affect many applications. Version 3.14.0 patches the issue. If an application does allow attacker controlled files to be loaded, a workaround on older releases would be to sanitize the files before loading.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-34993?

3 open source packages ship an affected version, including aiohttp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiohttp` | PyPI | All versions | 3.14.0 |
| `aiohttp` | PyPI | All versions | 3.14.0 |
| `aiohttp` | PyPI | All versions | 3.14.0 |
| `python-aiohttp` | openSUSE:Tumbleweed | All versions | 3.14.0-1.1 |

Products: Aiohttp Aiohttp.

## How do I fix CVE-2026-34993?

Upgrade aiohttp to 3.14.0 or later.

## Is CVE-2026-34993 being exploited?

There is no known exploitation of CVE-2026-34993 in the wild and no public exploit code.

## Other vulnerabilities in aio-libs aiohttp

- [CVE-2024-52303](https://insights.sbomify.com/CVE-2024-52303/): aiohttp memory leak when middleware is enabled when requesting a resource with a non-allowed method (high 8.7)
- [CVE-2025-69223](https://insights.sbomify.com/CVE-2025-69223/): AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb (high 7.5)
- [CVE-2024-30251](https://insights.sbomify.com/CVE-2024-30251/): Denial of service when trying to parse malformed POST requests in aiohttp (high 7.5)
- [CVE-2023-49081](https://insights.sbomify.com/CVE-2023-49081/): aiohttp's ClientSession is vulnerable to CRLF injection via version (high 7.2)
- [CVE-2026-22815](https://insights.sbomify.com/CVE-2026-22815/): AIOHTTP: Uncapped memory usage possible through aiohttp allowing unlimited trailer headers (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-34993 and fix it if it is affected.

What it is: CVE-2026-34993 is a medium-severity unsafe deserialization vulnerability in aio-libs aiohttp, published on 2 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-34993 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiohttp (PyPI): affected all versions; fixed in 3.14.0
- aiohttp (PyPI): affected all versions; fixed in 3.14.0
- aiohttp (PyPI): affected all versions; fixed in 3.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-34993/ (Markdown: https://insights.sbomify.com/CVE-2026-34993/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-34993
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-34993
- OSV: https://osv.dev/vulnerability/CVE-2026-34993

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-34993/
Summaries are generated and may contain mistakes; the official description above is the record.
