# CVE-2026-35002: Agno < 2.3.24 field_type Eval Injection Arbitrary Code Execution

> Attackers can execute arbitrary Python code by manipulating the field_type parameter in Agno's model execution component.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-77rh-m34w-rv36, GHSA-m4w4-3r8h-jw98, PYSEC-2026-256

## What is CVE-2026-35002?

CVE-2026-35002 is a critical code injection vulnerability in Agno, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Agno versions prior to 2.3.24 contain an arbitrary code execution vulnerability in the model execution component that allows attackers to execute arbitrary Python code by manipulating the field_type parameter passed to eval(). Attackers can influence the field_type value in a FunctionCall to achieve remote code execution.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2026-35002?

5 open source packages ship an affected version, including agno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `agno` | PyPI | All versions | 2.3.24 |
| `agno` | PyPI | All versions | 2.3.24 |
| `agno` | PyPI | All versions | 2.3.24 |
| `agno` | PyPI | All versions | 2.3.24 |
| `agno` | PyPI | All versions | 2.3.24 |

Products: Agno Agno.

## How do I fix CVE-2026-35002?

Upgrade agno to 2.3.24 or later.

## Is CVE-2026-35002 being exploited?

There is no known exploitation of CVE-2026-35002 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35002 and fix it if it is affected.

What it is: CVE-2026-35002 is a critical code injection vulnerability in Agno, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-35002 in the wild and no public exploit code.

Affected packages and fixed versions:
- agno (PyPI): affected all versions; fixed in 2.3.24
- agno (PyPI): affected all versions; fixed in 2.3.24
- agno (PyPI): affected all versions; fixed in 2.3.24
- agno (PyPI): affected all versions; fixed in 2.3.24
- agno (PyPI): affected all versions; fixed in 2.3.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35002/ (Markdown: https://insights.sbomify.com/CVE-2026-35002/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35002
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35002
- OSV: https://osv.dev/vulnerability/CVE-2026-35002

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35002/
Summaries are generated and may contain mistakes; the official description above is the record.
