# CVE-2026-35029: LiteLLM affected by privilege escalation via unrestricted proxy configuration endpoint

> Authenticated users can modify proxy configuration to execute arbitrary code, read files, and take over accounts due to missing admin authorization checks.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLEANSTART-2026-EM91124, ECHO-f909-9693-1f3f, GHSA-53mr-6c8q-9789, MINI-2rwg-cq7w-wc9v, MINI-4pjf-mrrv-cpgh, MINI-cvx3-55p8-mpgf, MINI-mcqq-966p-r7m3, MINI-x4mw-v99r-hpjm, PYSEC-2026-2597

## What is CVE-2026-35029?

CVE-2026-35029 is a high-severity missing authorization vulnerability in BerriAI litellm, published on 6 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.0, the /config/update endpoint does not enforce admin role authorization. A user who is already authenticated into the platform can then use this endpoint to modify proxy configuration and environment variables, register custom pass-through endpoint handlers pointing to attacker-controlled Python code, achieving remote code execution, read arbitrary server files by setting UI_LOGO_PATH and fetching via /get_image, and take over other privileged accounts by overwriting UI_USERNAME and UI_PASSWORD environment variables. Fixed in v1.83.0.

Weakness: CWE-425 (Direct Request), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-35029?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.83.0 |
| `litellm` | PyPI | All versions | 1.83.0 |
| `litellm` | PyPI | All versions | 1.83.0 |

Products: Litellm Litellm.

## How do I fix CVE-2026-35029?

Upgrade litellm to 1.83.0 or later.

## Is CVE-2026-35029 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35029 exists.

Public exploit code:

- The code for personally reproducing the corresponding vulnerability (github_poc): https://github.com/learner202649/CVE-2026-35029-PoC
- LiteLLM - Arbitrary File Read (nuclei): http/cves/2026/CVE-2026-35029.yaml

## Other vulnerabilities in BerriAI litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35029 and fix it if it is affected.

What it is: CVE-2026-35029 is a high-severity missing authorization vulnerability in BerriAI litellm, published on 6 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35029 exists.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.83.0
- litellm (PyPI): affected all versions; fixed in 1.83.0
- litellm (PyPI): affected all versions; fixed in 1.83.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35029/ (Markdown: https://insights.sbomify.com/CVE-2026-35029/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35029
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35029
- OSV: https://osv.dev/vulnerability/CVE-2026-35029

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35029/
Summaries are generated and may contain mistakes; the official description above is the record.
