# CVE-2026-35030: LiteLLM has an authentication bypass via OIDC userinfo cache key collision

> An attacker can bypass authentication and impersonate users by exploiting OIDC cache key collisions in LiteLLM when JWT authentication is enabled.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLEANSTART-2026-JK38146, GHSA-jjhc-v7c2-5hh6, MINI-975h-r96j-7xm6, MINI-gc87-9qh7-xh7p, MINI-gv7r-cjh8-p958, MINI-wjjm-x2wv-75pw, MINI-xr28-j2m8-h74x, PYSEC-2026-390

## What is CVE-2026-35030?

CVE-2026-35030 is a critical authentication bypass vulnerability in BerriAI litellm, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.0, when JWT authentication is enabled (enable_jwt_auth: true), the OIDC userinfo cache uses token[:20] as the cache key. JWT headers produced by the same signing algorithm generate identical first 20 characters. This configuration option is not enabled by default. Most instances are not affected. An unauthenticated attacker can craft a token whose first 20 characters match a legitimate user's cached token. On cache hit, the attacker inherits the legitimate user's identity and permissions. This affects deployments with JWT/OIDC authentication enabled. Fixed in v1.83.0.

Weakness: CWE-222 (Truncation of Security-relevant Information), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-35030?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.83.0 |
| `litellm` | PyPI | All versions | 1.83.0 |
| `litellm` | PyPI | All versions | 1.83.0 |

Products: Litellm Litellm.

## How do I fix CVE-2026-35030?

Upgrade litellm to 1.83.0 or later.

## Is CVE-2026-35030 being exploited?

There is no known exploitation of CVE-2026-35030 in the wild and no public exploit code.

Public exploit code:

- The code for personally reproducing the corresponding vulnerability (github_poc): https://github.com/learner202649/CVE-2026-35030-PoC

## Other vulnerabilities in BerriAI litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35030 and fix it if it is affected.

What it is: CVE-2026-35030 is a critical authentication bypass vulnerability in BerriAI litellm, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-35030 in the wild and no public exploit code.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.83.0
- litellm (PyPI): affected all versions; fixed in 1.83.0
- litellm (PyPI): affected all versions; fixed in 1.83.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35030/ (Markdown: https://insights.sbomify.com/CVE-2026-35030/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35030
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35030
- OSV: https://osv.dev/vulnerability/CVE-2026-35030

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35030/
Summaries are generated and may contain mistakes; the official description above is the record.
