# CVE-2026-35036: Ech0 Affected by Unauthenticated Server-Side Request Forgery in Website Preview Feature

> Unauthenticated attackers can force the Ech0 server to make arbitrary HTTP requests, potentially accessing internal network resources or sensitive data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** GHSA-wc4h-2348-jc3p, GO-2026-5704

## What is CVE-2026-35036?

CVE-2026-35036 is a high-severity server-side request forgery vulnerability in lin-snow Ech0, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ech0 is an open-source, self-hosted publishing platform for personal idea sharing. Prior to 4.2.8, Ech0 implements link preview (editor fetches a page title) through GET /api/website/title. That is legitimate product behavior, but the implementation is unsafe: the route is unauthenticated, accepts a fully attacker-controlled URL, performs a server-side GET, reads the entire response body into memory (io.ReadAll). There is no host allowlist, no SSRF filter, and InsecureSkipVerify: true on the outbound client. Anyone who can reach the instance can force the Ech0 server to open HTTP/HTTPS URLs of their choice as seen from the server’s network position (Docker bridge, VPC, localhost from the process view). This vulnerability is fixed in 4.2.8.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-35036?

3 open source packages ship an affected version, including github.com/lin-snow/ech0. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lin-snow/ech0` | Go | All versions | 1.4.8-0.20260401031029-4ca56fea5ba4 |
| `github.com/lin-snow/ech0` | Go | All versions | 1.4.8-0.20260401031029-4ca56fea5ba4 |
| `github.com/lin-snow/ech0` | Go | All versions | 1.4.8-0.20260401031029-4ca56fea5ba4 |

Products: Ech0 Ech0.

## How do I fix CVE-2026-35036?

Upgrade github.com/lin-snow/ech0 to 1.4.8-0.20260401031029-4ca56fea5ba4 or later.

## Is CVE-2026-35036 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35036 exists.

## Other vulnerabilities in lin-snow Ech0

- [CVE-2026-35037](https://insights.sbomify.com/CVE-2026-35037/): Ech0 affected by unauthenticated SSRF in GetWebsiteTitle allows access to internal services and cloud metadata (high 7.2)
- [CVE-2026-33638](https://insights.sbomify.com/CVE-2026-33638/): Ech0 authenticated user-list exposed data via public `/api/allusers` endpoint (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35036 and fix it if it is affected.

What it is: CVE-2026-35036 is a high-severity server-side request forgery vulnerability in lin-snow Ech0, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35036 exists.

Affected packages and fixed versions:
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 1.4.8-0.20260401031029-4ca56fea5ba4
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 1.4.8-0.20260401031029-4ca56fea5ba4
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 1.4.8-0.20260401031029-4ca56fea5ba4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35036/ (Markdown: https://insights.sbomify.com/CVE-2026-35036/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35036
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35036
- OSV: https://osv.dev/vulnerability/CVE-2026-35036

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35036/
Summaries are generated and may contain mistakes; the official description above is the record.
