# CVE-2026-35044: BentoML has a Server-Side Template Injection via unsandboxed Jinja2 Environment in Dockerfile generation

> Attackers can execute arbitrary Python code on the host by tricking users into containerizing a malicious bento archive using BentoML.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Apr 2026
- **Updated:** 6 Apr 2026
- **Also known as:** GHSA-v959-cwq9-7hr6, PYSEC-2026-159

## What is CVE-2026-35044?

CVE-2026-35044 is a high-severity code injection vulnerability in BentoML, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

BentoML is a Python library for building online serving systems optimized for AI apps and model inference. Prior to 1.4.38, the Dockerfile generation function generate_containerfile() in src/bentoml/_internal/container/generate.py uses an unsandboxed jinja2.Environment with the jinja2.ext.do extension to render user-provided dockerfile_template files. When a victim imports a malicious bento archive and runs bentoml containerize, attacker-controlled Jinja2 template code executes arbitrary Python directly on the host machine, bypassing all container isolation. This vulnerability is fixed in 1.4.38.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-35044?

3 open source packages ship an affected version, including bentoml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bentoml` | PyPI | All versions | 1.4.38 |
| `bentoml` | PyPI | All versions | 1.4.38 |
| `bentoml` | PyPI | All versions | 1.4.38 |

Products: Bentoml Bentoml.

## How do I fix CVE-2026-35044?

Upgrade bentoml to 1.4.38 or later.

## Is CVE-2026-35044 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35044 exists.

## Other vulnerabilities in BentoML

- [CVE-2025-54381](https://insights.sbomify.com/CVE-2025-54381/): BentoML is Vulnerable to an SSRF Attack Through File Upload Processing (critical 9.9)
- [CVE-2025-32375](https://insights.sbomify.com/CVE-2025-32375/): Insecure Deserialization leads to RCE in BentoML's runner server (critical 9.8)
- [CVE-2025-27520](https://insights.sbomify.com/CVE-2025-27520/): BentoML Allows Remote Code Execution (RCE) via Insecure Deserialization (critical 9.8)
- [CVE-2026-44345](https://insights.sbomify.com/CVE-2026-44345/): BentoML: Dockerfile command injection via docker.base_image (high 8.8)
- [CVE-2026-44346](https://insights.sbomify.com/CVE-2026-44346/): BentoML: Dockerfile command injection via envs[*].name in bentofile.yaml (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35044 and fix it if it is affected.

What it is: CVE-2026-35044 is a high-severity code injection vulnerability in BentoML, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35044 exists.

Affected packages and fixed versions:
- bentoml (PyPI): affected all versions; fixed in 1.4.38
- bentoml (PyPI): affected all versions; fixed in 1.4.38
- bentoml (PyPI): affected all versions; fixed in 1.4.38

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35044/ (Markdown: https://insights.sbomify.com/CVE-2026-35044/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35044
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35044
- OSV: https://osv.dev/vulnerability/CVE-2026-35044

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35044/
Summaries are generated and may contain mistakes; the official description above is the record.
