# CVE-2026-3505: Unbounded PGP AEAD chunk size leads to pre-auth resource exhaustion.

> Attackers can cause resource exhaustion in BC-JAVA by sending unbounded PGP AEAD chunk sizes, requiring an upgrade to patched versions.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 18 Sep 2026
- **Also known as:** CLEANSTART-2026-UF42404, CLEANSTART-2026-UH58256, CLSA-2026-1789213301, CLSA-2026-1792700416, DEBIAN-CVE-2026-3505, ECHO-4c5b-c10c-c548, GHSA-cj8j-37rh-8475, MINI-27c4-5h64-rrph, MINI-2p99-j43w-3f42, MINI-4p4m-mxq3-vwcr, MINI-68qq-24gm-wjpr, MINI-cvfq-c3rc-7m5p, MINI-f64r-pc2v-49hg, MINI-hr3h-c6r5-54hr, MINI-j58v-9r28-688h, MINI-v5ch-vc52-77vr, MINI-xppv-c284-7vxf, ROOT-APP-MAVEN-CVE-2026-3505, UBUNTU-CVE-2026-3505

## What is CVE-2026-3505?

CVE-2026-3505 is a high-severity denial of service vulnerability in Legion of the Bouncy Castle Inc. BC-JAVA, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Allocation of resources without limits or throttling, Uncontrolled Resource Consumption vulnerability in Legion of the Bouncy Castle Inc. BC-JAVA bcpg on all (pg modules).

 This vulnerability is associated with program files AEADEncDataPacket.Java, BcAEADUtil.Java, JceAEADUtil.Java, OperatorHelper.Java.

This issue affects BC-JAVA: from 1.74 before 1.80.2, from 1.81 before 1.81.1, from 1.82 before 1.84.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-3505?

14 open source packages ship an affected version, including org.bouncycastle:bcpg-jdk12, org.bouncycastle:bcpg-jdk14 and org.bouncycastle:bcpg-jdk15.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.bouncycastle:bcpg-jdk12` | Maven | All versions to 130 | None |
| `org.bouncycastle:bcpg-jdk12` | Maven | All versions to 130 | None |
| `org.bouncycastle:bcpg-jdk14` | Maven | All versions | 1.84 |
| `org.bouncycastle:bcpg-jdk14` | Maven | All versions | 1.84 |
| `org.bouncycastle:bcpg-jdk15` | Maven | All versions to 1.46 | None |
| `org.bouncycastle:bcpg-jdk15` | Maven | All versions to 1.46 | None |
| `org.bouncycastle:bcpg-jdk15on` | Maven | All versions to 1.70 | None |
| `org.bouncycastle:bcpg-jdk15on` | Maven | All versions to 1.70 | None |
| `org.bouncycastle:bcpg-jdk15to18` | Maven | All versions | 1.84 |
| `org.bouncycastle:bcpg-jdk15to18` | Maven | All versions | 1.84 |
| `org.bouncycastle:bcpg-jdk16` | Maven | All versions to 1.46 | None |
| `org.bouncycastle:bcpg-jdk16` | Maven | All versions to 1.46 | None |
| `org.bouncycastle:bcpg-jdk18on` | Maven | All versions | 1.84 |
| `org.bouncycastle:bcpg-jdk18on` | Maven | All versions | 1.84 |

## How do I fix CVE-2026-3505?

Upgrade to a fixed version.

## Is CVE-2026-3505 being exploited?

There is no known exploitation of CVE-2026-3505 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-3505 and fix it if it is affected.

What it is: CVE-2026-3505 is a high-severity denial of service vulnerability in Legion of the Bouncy Castle Inc. BC-JAVA, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-3505 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.bouncycastle:bcpg-jdk12 (Maven): affected all versions up to 130; no fix listed
- org.bouncycastle:bcpg-jdk12 (Maven): affected all versions up to 130; no fix listed
- org.bouncycastle:bcpg-jdk14 (Maven): affected all versions; fixed in 1.84
- org.bouncycastle:bcpg-jdk14 (Maven): affected all versions; fixed in 1.84
- org.bouncycastle:bcpg-jdk15 (Maven): affected all versions up to 1.46; no fix listed
- org.bouncycastle:bcpg-jdk15 (Maven): affected all versions up to 1.46; no fix listed
- org.bouncycastle:bcpg-jdk15on (Maven): affected all versions up to 1.70; no fix listed
- org.bouncycastle:bcpg-jdk15on (Maven): affected all versions up to 1.70; no fix listed
- org.bouncycastle:bcpg-jdk15to18 (Maven): affected all versions; fixed in 1.84
- org.bouncycastle:bcpg-jdk15to18 (Maven): affected all versions; fixed in 1.84
- org.bouncycastle:bcpg-jdk16 (Maven): affected all versions up to 1.46; no fix listed
- org.bouncycastle:bcpg-jdk16 (Maven): affected all versions up to 1.46; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-3505/ (Markdown: https://insights.sbomify.com/CVE-2026-3505/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-3505
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-3505
- OSV: https://osv.dev/vulnerability/CVE-2026-3505

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-3505/
Summaries are generated and may contain mistakes; the official description above is the record.
