# CVE-2026-35163: OctoPrint: XSS in Suppressed Command Notifications

> Attackers can inject JavaScript into OctoPrint notifications via crafted print files, allowing session hijacking and data theft.

- **Severity:** Medium 4.6 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:L/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** GHSA-p6qx-ghxm-389h, PYSEC-2026-2688

## What is CVE-2026-35163?

CVE-2026-35163 is a medium-severity cross-site scripting vulnerability in OctoPrint, published on 21 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OctoPrint provides a web interface for controlling consumer 3D printers. Prior to 1.11.8 and 2.0.0rc3, Suppressed Command notification popups use PNotify rendering for printer-controlled payload.command and payload.message values in src/octoprint/static/js/app/viewmodels/terminal.js without HTML escaping. An attacker who convinces a victim to print a crafted file can inject HTML and JavaScript into the notification, disrupt prints, read information available to the victim including sensitive settings when permitted, or perform actions in the victim's OctoPrint session. This issue is fixed in versions 1.11.8 and 2.0.0rc3.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2026-35163?

5 open source packages ship an affected version, including octoprint and OctoPrint.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `octoprint` | PyPI | All versions | 1.11.8, 2.0.0rc3 |
| `octoprint` | PyPI | All versions | 1.11.8 |
| `octoprint` | PyPI | From 2.0.0rc1 | 2.0.0rc3 |
| `OctoPrint` | PyPI | All versions | 1.11.8 |
| `OctoPrint` | PyPI | From 2.0.0rc1 | 2.0.0rc3 |

## How do I fix CVE-2026-35163?

Upgrade octoprint to a fixed version for your release line: 1.11.8 or 2.0.0rc3.

## Is CVE-2026-35163 being exploited?

There is no known exploitation of CVE-2026-35163 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35163 and fix it if it is affected.

What it is: CVE-2026-35163 is a medium-severity cross-site scripting vulnerability in OctoPrint, published on 21 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-35163 in the wild and no public exploit code.

Affected packages and fixed versions:
- octoprint (PyPI): affected all versions; fixed in 1.11.8, 2.0.0rc3
- octoprint (PyPI): affected all versions; fixed in 1.11.8
- octoprint (PyPI): affected from 2.0.0rc1; fixed in 2.0.0rc3
- OctoPrint (PyPI): affected all versions; fixed in 1.11.8
- OctoPrint (PyPI): affected from 2.0.0rc1; fixed in 2.0.0rc3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35163/ (Markdown: https://insights.sbomify.com/CVE-2026-35163/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35163
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35163
- OSV: https://osv.dev/vulnerability/CVE-2026-35163

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35163/
Summaries are generated and may contain mistakes; the official description above is the record.
