# CVE-2026-35174: Chyrp Lite has a Path Traversal to Remote Code Execution

> Administrators can exploit path traversal to read sensitive files and overwrite system files, leading to remote code execution.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** GHSA-p6pf-2grm-8257

## What is CVE-2026-35174?

CVE-2026-35174 is a critical path traversal vulnerability in xenocrat chyrp-lite, published on 6 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Chyrp Lite is an ultra-lightweight blogging engine. Prior to 2026.01, a path traversal vulnerability exists in the administration console that allows an administrator or a user with Change Settings permission to change the uploads path to any folder. This vulnerability allows the user to download any file on the server, including config.json.php with database credentials and overwrite critical system files, leading to remote code execution. This vulnerability is fixed in 2026.01.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type), CWE-73 (External Control of File Name or Path), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-35174?

It affects 1 product.


Products: Chyrplite Chyrp Lite.

## How do I fix CVE-2026-35174?

No fix has been published for CVE-2026-35174 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-35174 being exploited?

There is no known exploitation of CVE-2026-35174 in the wild and no public exploit code.

## Other vulnerabilities in xenocrat chyrp-lite

- [CVE-2026-35173](https://insights.sbomify.com/CVE-2026-35173/): Chyrp Lite has an IDOR via Mass Assignment in Post Model (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35174 and fix it if it is affected.

What it is: CVE-2026-35174 is a critical path traversal vulnerability in xenocrat chyrp-lite, published on 6 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-35174 in the wild and no public exploit code.

Affected product: xenocrat chyrp-lite. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35174/ (Markdown: https://insights.sbomify.com/CVE-2026-35174/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35174
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35174
- OSV: https://osv.dev/vulnerability/CVE-2026-35174

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35174/
Summaries are generated and may contain mistakes; the official description above is the record.
