{"answers":{"affected":"3 open source packages ship an affected version, including ajenti-panel. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-35175 in the wild and no public exploit code.","fix":"Upgrade ajenti-panel to 2.2.15 or later.","what":"CVE-2026-35175 is a high-severity missing authorization vulnerability in ajenti, published on 6 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-35175 and fix it if it is affected.\n\nWhat it is: CVE-2026-35175 is a high-severity missing authorization vulnerability in ajenti, published on 6 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-35175 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ajenti-panel (PyPI): affected all versions; fixed in 2.2.15\n- ajenti-panel (PyPI): affected all versions; fixed in 2.2.15\n- ajenti-panel (PyPI): affected all versions; fixed in 2.2.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-35175/ (Markdown: https://insights.sbomify.com/CVE-2026-35175/index.md)","id":"CVE-2026-35175","markdown":"https://insights.sbomify.com/CVE-2026-35175/index.md","name":"CVE-2026-35175","record":{"aliases":["GHSA-73jv-44c3-j5p2","PYSEC-2026-2339"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ajenti admin panel","requires_auth":"low_privilege","summary":"Authenticated non-superuser attackers can install custom packages, leading to privilege escalation and potential code execution.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ajenti","vendor":"ajenti"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:L/SC:L/SI:L/SA:L","version":"4.0"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Ajenti is a Linux and BSD modular server admin panel. Prior to 2.2.15, an authenticated user (using the auth_users plugin authentication method) could install a custom package even if this user is not superuser. This vulnerability is fixed in 2.2.15.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ajenti has an authorization bypass during custom package installation","id":"CVE-2026-35175","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"openFPGALoader has a heap buffer overflow in POFParser::parseSection() via crafted .pof file","id":"CVE-2026-35176"},"packages":[{"ecosystem":"PyPI","fixed":["2.2.15"],"introduced":["0"],"last_affected":[],"package":"ajenti-panel","purl":null,"source":"GHSA-73jv-44c3-j5p2"},{"ecosystem":"PyPI","fixed":["2.2.15"],"introduced":["0"],"last_affected":[],"package":"ajenti-panel","purl":"pkg:pypi/ajenti-panel","source":"GHSA-73jv-44c3-j5p2"},{"ecosystem":"PyPI","fixed":["2.2.15"],"introduced":["0"],"last_affected":[],"package":"ajenti-panel","purl":"pkg:pypi/ajenti-panel","source":"PYSEC-2026-2339"}],"prev":{"headline":"Chyrp Lite has a Path Traversal to Remote Code Execution","id":"CVE-2026-35174"},"products":["ajenti"],"published":"2026-04-06","related":[{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2018-1000082","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":8.1,"headline":"Ajenti has a potential Remote Code Execution","id":"CVE-2026-27975","kev_date_added":null,"published":"2026-02-26"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2018-1000081","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":7.5,"headline":"Information disclosure in n/a","id":"CVE-2018-1000126","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":6.5,"headline":"Missing authorization in n/a","id":"CVE-2018-1000080","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":6.3,"headline":"ajenti API privileges management","id":"CVE-2019-25066","kev_date_added":null,"published":"2022-06-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-07","vendors":["ajenti"]},"summary":"Authenticated non-superuser attackers can install custom packages, leading to privilege escalation and potential code execution.","url":"https://insights.sbomify.com/CVE-2026-35175/"}