CVE-2026-35177 Path traversal issue with zip.vim in Vim
Attackers can overwrite arbitrary files by tricking users into opening specially crafted zip archives in Vim.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-35177?
CVE-2026-35177 is a medium-severity path traversal vulnerability in Vim Vim, published on 6 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Vim is an open source, command line text editor. Prior to 9.2.0280, a path traversal bypass in Vim's zip.vim plugin allows overwriting of arbitrary files when opening specially crafted zip archives, circumventing the previous fix for CVE-2025-53906. This vulnerability is fixed in 9.2.0280.
Weakness: CWE-22
Which versions are affected by CVE-2026-35177?
It affects 1 product.
Linux distribution packages (26)
vim-X11 AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.3 |
vim-common AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.3 |
vim-data AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.3 |
vim-enhanced AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.3 |
vim-filesystem AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.3 |
vim-minimal AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.3 |
xxd AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.3 |
vim-X11 AlmaLinux:8 | All versions | 2:8.0.1763-23.el8_10 |
vim-common AlmaLinux:8 | All versions | 2:8.0.1763-23.el8_10 |
vim-enhanced AlmaLinux:8 | All versions | 2:8.0.1763-23.el8_10 |
vim-filesystem AlmaLinux:8 | All versions | 2:8.0.1763-23.el8_10 |
vim-minimal AlmaLinux:8 | All versions | 2:8.0.1763-23.el8_10 |
vim-X11 AlmaLinux:9 | All versions | 2:8.2.2637-26.el9_8.5 |
vim-common AlmaLinux:9 | All versions | 2:8.2.2637-26.el9_8.5 |
vim-enhanced AlmaLinux:9 | All versions | 2:8.2.2637-26.el9_8.5 |
vim-filesystem AlmaLinux:9 | All versions | 2:8.2.2637-26.el9_8.5 |
vim-minimal AlmaLinux:9 | All versions | 2:8.2.2637-26.el9_8.5 |
vim Red Hat:enterprise_linux:10.2 | All versions | 2:9.1.083-9.el10_2.3 |
vim-common Red Hat:enterprise_linux:10.2 | All versions | 2:9.1.083-9.el10_2.3 |
vim-common Red Hat:enterprise_linux:8::appstream | All versions | 2:8.0.1763-23.el8_10 |
vim Red Hat:enterprise_linux:8::baseos | All versions | 2:8.0.1763-23.el8_10 |
vim-common Red Hat:enterprise_linux:9::appstream | All versions | 2:8.2.2637-26.el9_8.5 |
vim Red Hat:enterprise_linux:9::baseos | All versions | 2:8.2.2637-26.el9_8.5 |
vim Rocky Linux:10 | All versions | 2:9.1.083-9.el10_2.3 |
vim Rocky Linux:8 | All versions | 2:8.0.1763-23.el8_10 |
vim Rocky Linux:9 | All versions | 2:8.2.2637-26.el9_8.5 |
Products include Vim Vim.
How do I fix CVE-2026-35177?
Upgrade to a fixed version.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2026-35177 being exploited?
There is no known exploitation of CVE-2026-35177 in the wild and no public exploit code.
Other vulnerabilities in Vim Vim
Sources
Also known as ALPINE-CVE-2026-35177, ALSA-2026:22711, ALSA-2026:22717, ALSA-2026:22730, AZL-81917, BELL-CVE-2026-35177 and 15 more.