# CVE-2026-35177: Path traversal issue with zip.vim in Vim

> Attackers can overwrite arbitrary files by tricking users into opening specially crafted zip archives in Vim.

- **Severity:** Medium 4.1 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** ALPINE-CVE-2026-35177, ALSA-2026:22711, ALSA-2026:22717, ALSA-2026:22730, AZL-81917, BELL-CVE-2026-35177, CLSA-2026-1792486744, CLSA-2026-1792577361, DEBIAN-CVE-2026-35177, ECHO-33bb-95d6-b867, GHSA-jc86-w7vm-8p24, OESA-2026-2177, RHSA-2026:22711, RHSA-2026:22717, RHSA-2026:22730, RLSA-2026:22711, RLSA-2026:22717, RLSA-2026:22730, ROOT-OS-DEBIAN-11-CVE-2026-35177, ROOT-OS-DEBIAN-12-CVE-2026-35177, UBUNTU-CVE-2026-35177

## What is CVE-2026-35177?

CVE-2026-35177 is a medium-severity path traversal vulnerability in Vim Vim, published on 6 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Vim is an open source, command line text editor. Prior to 9.2.0280, a path traversal bypass in Vim's zip.vim plugin allows overwriting of arbitrary files when opening specially crafted zip archives, circumventing the previous fix for CVE-2025-53906. This vulnerability is fixed in 9.2.0280.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-35177?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vim-X11` | AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.3 |
| `vim-common` | AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.3 |
| `vim-data` | AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.3 |
| `vim-enhanced` | AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.3 |
| `vim-filesystem` | AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.3 |
| `vim-minimal` | AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.3 |
| `xxd` | AlmaLinux:10 | All versions | 2:9.1.083-9.el10_2.3 |
| `vim-X11` | AlmaLinux:8 | All versions | 2:8.0.1763-23.el8_10 |
| `vim-common` | AlmaLinux:8 | All versions | 2:8.0.1763-23.el8_10 |
| `vim-enhanced` | AlmaLinux:8 | All versions | 2:8.0.1763-23.el8_10 |
| `vim-filesystem` | AlmaLinux:8 | All versions | 2:8.0.1763-23.el8_10 |
| `vim-minimal` | AlmaLinux:8 | All versions | 2:8.0.1763-23.el8_10 |
| `vim-X11` | AlmaLinux:9 | All versions | 2:8.2.2637-26.el9_8.5 |
| `vim-common` | AlmaLinux:9 | All versions | 2:8.2.2637-26.el9_8.5 |
| `vim-enhanced` | AlmaLinux:9 | All versions | 2:8.2.2637-26.el9_8.5 |
| `vim-filesystem` | AlmaLinux:9 | All versions | 2:8.2.2637-26.el9_8.5 |
| `vim-minimal` | AlmaLinux:9 | All versions | 2:8.2.2637-26.el9_8.5 |
| `vim` | Red Hat:enterprise_linux:10.2 | All versions | 2:9.1.083-9.el10_2.3 |
| `vim-common` | Red Hat:enterprise_linux:10.2 | All versions | 2:9.1.083-9.el10_2.3 |
| `vim-common` | Red Hat:enterprise_linux:8::appstream | All versions | 2:8.0.1763-23.el8_10 |
| `vim` | Red Hat:enterprise_linux:8::baseos | All versions | 2:8.0.1763-23.el8_10 |
| `vim-common` | Red Hat:enterprise_linux:9::appstream | All versions | 2:8.2.2637-26.el9_8.5 |
| `vim` | Red Hat:enterprise_linux:9::baseos | All versions | 2:8.2.2637-26.el9_8.5 |
| `vim` | Rocky Linux:10 | All versions | 2:9.1.083-9.el10_2.3 |
| `vim` | Rocky Linux:8 | All versions | 2:8.0.1763-23.el8_10 |
| `vim` | Rocky Linux:9 | All versions | 2:8.2.2637-26.el9_8.5 |

Products: Vim Vim.

## How do I fix CVE-2026-35177?

Upgrade to a fixed version.

## Is CVE-2026-35177 being exploited?

There is no known exploitation of CVE-2026-35177 in the wild and no public exploit code.

## Other vulnerabilities in Vim Vim

- [CVE-2020-20703](https://insights.sbomify.com/CVE-2020-20703/): Memory corruption in n/a (critical 9.8)
- [CVE-2017-6349](https://insights.sbomify.com/CVE-2017-6349/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-6350](https://insights.sbomify.com/CVE-2017-6350/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-5953](https://insights.sbomify.com/CVE-2017-5953/): Integer overflow in n/a (critical 9.8)
- [CVE-2008-3075](https://insights.sbomify.com/CVE-2008-3075/): Command injection in n/a (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35177 and fix it if it is affected.

What it is: CVE-2026-35177 is a medium-severity path traversal vulnerability in Vim Vim, published on 6 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-35177 in the wild and no public exploit code.

Affected product: Vim Vim. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35177/ (Markdown: https://insights.sbomify.com/CVE-2026-35177/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35177
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35177
- OSV: https://osv.dev/vulnerability/CVE-2026-35177

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35177/
Summaries are generated and may contain mistakes; the official description above is the record.
