{"answers":{"affected":"2 open source packages ship an affected version, including multer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-3520 in the wild and no public exploit code.","fix":"Upgrade multer to 2.1.1 or later.","what":"CVE-2026-3520 is a high-severity denial of service vulnerability in expressjs multer, published on 4 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-3520 and fix it if it is affected.\n\nWhat it is: CVE-2026-3520 is a high-severity denial of service vulnerability in expressjs multer, published on 4 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-3520 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- multer (npm): affected all versions; fixed in 2.1.1\n- multer (npm): affected all versions; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-3520/ (Markdown: https://insights.sbomify.com/CVE-2026-3520/index.md)","id":"CVE-2026-3520","markdown":"https://insights.sbomify.com/CVE-2026-3520/index.md","name":"CVE-2026-3520","record":{"aliases":["ECHO-8994-222a-8499","GHSA-5528-5vmv-3xc2","MINI-2266-hqgj-fvp4","ROOT-APP-NPM-CVE-2026-3520"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js multipart middleware","requires_auth":"none","summary":"An attacker can cause a denial of service via stack overflow by sending malformed multipart requests to applications using this Node.js middleware.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[{"product":"multer","vendor":"expressjs"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"},{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.1 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing stack overflow. Users should upgrade to version 2.1.1 to receive a patch. No known workarounds are available.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Multer vulnerable to Denial of Service via uncontrolled recursion","id":"CVE-2026-3520","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Apocalypse Meow \u003c= 22.1.0 - Authenticated (Administrator+) SQL Injection via 'type' Parameter","id":"CVE-2026-3523"},"packages":[{"ecosystem":"npm","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"multer","purl":null,"source":"GHSA-5528-5vmv-3xc2"},{"ecosystem":"npm","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"multer","purl":"pkg:npm/multer","source":"GHSA-5528-5vmv-3xc2"}],"prev":{"headline":"Command injection in ECS Connections Manager","id":"CVE-2026-3519"},"products":["multer"],"published":"2026-03-04","related":[{"cvss_score":8.7,"headline":"Multer vulnerable to Denial of Service via resource exhaustion","id":"CVE-2026-2359","kev_date_added":null,"published":"2026-02-27"},{"cvss_score":8.7,"headline":"Multer vulnerable to Denial of Service via incomplete cleanup","id":"CVE-2026-3304","kev_date_added":null,"published":"2026-02-27"},{"cvss_score":7.5,"headline":"multer vulnerable to Denial of Service via file descriptor leak on aborted uploads","id":"CVE-2026-77037","kev_date_added":null,"published":"2026-08-28"},{"cvss_score":7.5,"headline":"multer vulnerable to Denial of Service via crafted multipart field names","id":"CVE-2026-77078","kev_date_added":null,"published":"2026-08-28"},{"cvss_score":7.5,"headline":"multer vulnerable to Denial of Service via oversized array index in field names","id":"CVE-2026-82333","kev_date_added":null,"published":"2026-08-28"},{"cvss_score":7.5,"headline":"multer vulnerable to Denial of Service via deeply nested field names","id":"CVE-2026-5079","kev_date_added":null,"published":"2026-06-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["expressjs"]},"summary":"An attacker can cause a denial of service via stack overflow by sending malformed multipart requests to applications using this Node.js middleware.","url":"https://insights.sbomify.com/CVE-2026-3520/"}