{"answers":{"affected":"2 open source packages ship an affected version, including rdiscount. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35201 exists.","fix":"Upgrade rdiscount to 2.2.7.4 or later.","what":"CVE-2026-35201 is a medium-severity memory corruption vulnerability in davidfstr rdiscount, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-35201 and fix it if it is affected.\n\nWhat it is: CVE-2026-35201 is a medium-severity memory corruption vulnerability in davidfstr rdiscount, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-35201 exists.\n\nAffected packages and fixed versions:\n- rdiscount (RubyGems): affected from 1.3.1.1; fixed in 2.2.7.4\n- rdiscount (RubyGems): affected from 1.3.1.1; fixed in 2.2.7.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-35201/ (Markdown: https://insights.sbomify.com/CVE-2026-35201/index.md)","id":"CVE-2026-35201","markdown":"https://insights.sbomify.com/CVE-2026-35201/index.md","name":"CVE-2026-35201","record":{"aliases":["AZL-82902","DEBIAN-CVE-2026-35201","GHSA-6r34-94wq-jhrc","UBUNTU-CVE-2026-35201"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Markdown parsing library","requires_auth":"none","summary":"An out-of-bounds read in the Discount Markdown parser allows attackers to crash the application by supplying inputs larger than INT_MAX.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"rdiscount","vendor":"dafoster"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"Discount is an implementation of John Gruber's Markdown markup language in C. From 1.3.1.1 to before 2.2.7.4, a signed length truncation bug causes an out-of-bounds read in the default Markdown parse path. Inputs larger than INT_MAX are truncated to a signed int before entering the native parser, allowing the parser to read past the end of the supplied buffer and crash the process. This vulnerability is fixed in 2.2.7.4.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Discount has an Out-of-bounds Read in rdiscount","id":"CVE-2026-35201","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Pterodactyl has a database resource limit bypass via race condition in Client API","id":"CVE-2026-35202"},"packages":[{"ecosystem":"RubyGems","fixed":["2.2.7.4"],"introduced":["1.3.1.1"],"last_affected":[],"package":"rdiscount","purl":null,"source":"GHSA-6r34-94wq-jhrc"},{"ecosystem":"RubyGems","fixed":["2.2.7.4"],"introduced":["1.3.1.1"],"last_affected":[],"package":"rdiscount","purl":"pkg:gem/rdiscount","source":"GHSA-6r34-94wq-jhrc"}],"prev":{"headline":"Parse Server has a file upload Content-Type override via extension mismatch","id":"CVE-2026-35200"},"products":["rdiscount"],"published":"2026-04-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-07","vendors":["davidfstr"]},"summary":"An out-of-bounds read in the Discount Markdown parser allows attackers to crash the application by supplying inputs larger than INT_MAX.","url":"https://insights.sbomify.com/CVE-2026-35201/"}