# CVE-2026-35202: Pterodactyl has a database resource limit bypass via race condition in Client API

> Attackers can bypass database allocation limits in Pterodactyl via a race condition in the Client API, allowing unauthorized resource usage.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2026
- **Updated:** 3 Jun 2026
- **Also known as:** GHSA-fgmm-w5cx-vrfw

## What is CVE-2026-35202?

CVE-2026-35202 is a low-severity vulnerability in pterodactyl panel, published on 2 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pterodactyl is a free, open-source game server management panel. Prior to version 1.12.3, the Pterodactyl Client API has a logic flaw that lets users bypass their assigned limits for database allocations. This happens because the database locking mechanism used in the controllers is totally broken and doesn't actually lock anything. Version 1.12.3 patches the issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-35202?

2 open source packages ship an affected version, including pterodactyl/panel.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pterodactyl/panel` | Packagist | All versions | 1.12.3 |
| `pterodactyl/panel` | Packagist | All versions | 1.12.3 |

## How do I fix CVE-2026-35202?

Upgrade pterodactyl/panel to 1.12.3 or later.

## Is CVE-2026-35202 being exploited?

There is no known exploitation of CVE-2026-35202 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35202 and fix it if it is affected.

What it is: CVE-2026-35202 is a low-severity vulnerability in pterodactyl panel, published on 2 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-35202 in the wild and no public exploit code.

Affected packages and fixed versions:
- pterodactyl/panel (Packagist): affected all versions; fixed in 1.12.3
- pterodactyl/panel (Packagist): affected all versions; fixed in 1.12.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35202/ (Markdown: https://insights.sbomify.com/CVE-2026-35202/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35202
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35202
- OSV: https://osv.dev/vulnerability/CVE-2026-35202

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35202/
Summaries are generated and may contain mistakes; the official description above is the record.
