# CVE-2026-35204: Helm has a path traversal in plugin metadata version enables arbitrary file write outside Helm plugin directory

> A path traversal in Helm plugin metadata allows attackers to write arbitrary files outside the plugin directory, potentially leading to code execution.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:L/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-helm-2026-35204, CLEANSTART-2026-SY10925, GHSA-vmx8-mqv2-9gmg, GO-2026-5666, MINI-5vhj-4f3c-j6hw, MINI-87mp-p83r-jvwg, MINI-8qrw-vjrc-h77j, MINI-g9v4-m7j5-gw54, MINI-mx33-cm6g-xf8v, MINI-q5qj-wv7f-4r44, MINI-v4q7-3cfg-fgf3, openSUSE-SU-2026:10526-1

## What is CVE-2026-35204?

CVE-2026-35204 is a high-severity path traversal vulnerability in helm, published on 9 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Helm is a package manager for Charts for Kubernetes. From 4.0.0 to 4.1.3, a specially crafted Helm plugin, when installed or updated, will cause Helm to write the contents of the plugin to an arbitrary filesystem location. To prevent this, validate that the plugin.yaml of the Helm plugin does not include a version: field containing POSIX dot-dot path separators ie. "/../". This vulnerability is fixed in 4.1.4.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-35204?

4 open source packages ship an affected version, including helm.sh/helm/v4 and helm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `helm.sh/helm/v4` | Go | From 4.0.0 | 4.1.4 |
| `helm.sh/helm/v4` | Go | From 4.0.0 | 4.1.4 |
| `helm.sh/helm/v4` | Go | From 4.0.0 | 4.1.4 |
| `helm` | Bitnami | From 4.0.0 | 4.1.4 |
| `helm` | openSUSE:Tumbleweed | All versions | 4.1.4-1.1 |

Products: Helm Helm.

## How do I fix CVE-2026-35204?

Upgrade helm.sh/helm/v4 to 4.1.4 or later.

## Is CVE-2026-35204 being exploited?

There is no known exploitation of CVE-2026-35204 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-35204 PoC (github_poc): https://github.com/h3ck13r/CVE-2026-35204

## Other vulnerabilities in helm

- [CVE-2019-18658](https://insights.sbomify.com/CVE-2019-18658/): Helm Unsafe Link Following (critical 9.8)
- [CVE-2019-1010275](https://insights.sbomify.com/CVE-2019-1010275/): Helm Improper Certificate Validation (critical 9.8)
- [CVE-2019-25210](https://insights.sbomify.com/CVE-2019-25210/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-53547](https://insights.sbomify.com/CVE-2025-53547/): Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution (high 8.5)
- [CVE-2020-11013](https://insights.sbomify.com/CVE-2020-11013/): lookup Function Information Discolosure in Helm (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35204 and fix it if it is affected.

What it is: CVE-2026-35204 is a high-severity path traversal vulnerability in helm, published on 9 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-35204 in the wild and no public exploit code.

Affected packages and fixed versions:
- helm.sh/helm/v4 (Go): affected from 4.0.0; fixed in 4.1.4
- helm.sh/helm/v4 (Go): affected from 4.0.0; fixed in 4.1.4
- helm.sh/helm/v4 (Go): affected from 4.0.0; fixed in 4.1.4
- helm (Bitnami): affected from 4.0.0; fixed in 4.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35204/ (Markdown: https://insights.sbomify.com/CVE-2026-35204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35204
- OSV: https://osv.dev/vulnerability/CVE-2026-35204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35204/
Summaries are generated and may contain mistakes; the official description above is the record.
