# CVE-2026-35207: Security feature bypass in dde-control-center

> An MITM attacker can bypass TLS verification to intercept avatar downloads, potentially identifying users or injecting malicious images.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 9 Apr 2026
- **Updated:** 13 Apr 2026
- **Also known as:** GHSA-jf2h-4vqc-3jgc

## What is CVE-2026-35207?

CVE-2026-35207 is a medium-severity vulnerability in linuxdeepin dde-control-center, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

dde-control-center is the control panel of DDE, the Deepin Desktop Environment. plugin-deepinid is a plugin in dde-control-center, which provides the deepinid cloud service. Prior to 6.1.80, plugin-deepinid is configured to skip TLS certificate verification when fetching the user's avatar from openapi.deepin.com or other providers. An MITM attacker could intercept the traffic, replace the avatar with a malicious or misleading image, and potentially identify the user by the avatar. This vulnerability is fixed in dde-control-center 6.1.80 and 5.9.9.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-35207?


## How do I fix CVE-2026-35207?

No fix has been published for CVE-2026-35207 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-35207 being exploited?

There is no known exploitation of CVE-2026-35207 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-35207 and fix it if it is affected.

What it is: CVE-2026-35207 is a medium-severity vulnerability in linuxdeepin dde-control-center, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-35207 in the wild and no public exploit code.

Affected product: linuxdeepin dde-control-center. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-35207/ (Markdown: https://insights.sbomify.com/CVE-2026-35207/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-35207
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-35207
- OSV: https://osv.dev/vulnerability/CVE-2026-35207

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-35207/
Summaries are generated and may contain mistakes; the official description above is the record.
